Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.1

PDF

Example: VXLAN with a controller configuration

This example shows a simple NSX controller and an hardware OS10 VTEP deployed in VXLAN environment.

NSX controller implementation

To configure an NSX controller-provisioned VXLAN:

  • Configure the controller and the interfaces to be managed by the controller, in the OS10 VTEPs
  • Configure the NSX controller in VMware vCenter. For more information about configuring the NSX controller using the GUI, see the Configure and control VXLAN from the VMware vCenter.

You must configure an OS10 VTEP with the controller configuration so that the VTEP can communicate with the NSX controller. The NSX controller handles configurations and control plane operations in the VXLAN environment.

VTEP 1

  1. Configure the OSPF protocol in the underlay.

    OS10# configure terminal
    OS10(config)# router ospf 1
    OS10(config)# exit
    OS10(config)# interface ethernet 1/1/55:1
    OS10(config-if-eth1/1/55:1)# no switchport
    OS10(config-if-eth1/1/55:1)# ip ospf 1 area 0.0.0.0
    OS10(config-if-eth1/1/55:1)# exit
    
  2. Configure a Loopback interface.

    OS10(config)# interface loopback 1
    OS10(config-if-lo-1)# no shutdown
    OS10(config-if-lo-1)# ip address 200.0.0.1/32
    OS10(config-if-lo-1)# exit
    
  3. Create an NVE instance and configure the Loopback interface as the VXLAN source tunnel interface.

    OS10(config)# nve
    OS10(config-nve)# source-interface loopback 1
    
  4. Specify the NSX controller reachability information.

    OS10(config-nve)# controller ovsdb
    OS10(config-nve-ovsdb)# ip 10.16.140.182 port 6640 ssl
    OS10(config-nve-ovsdb)# max-backoff 10000
    OS10(config-nve-ovsdb)# exit
    
  5. Assign interfaces to be managed by the controller.

    OS10(config)# interface ethernet 1/1/54:3
    OS10(config-if-eth1/1/54:3)# switchport mode trunk
    OS10(config-if-eth1/1/54:3)# no switchport access vlan
    OS10(config-if-eth1/1/54:3)# nve-controller
    
  6. (Optional) Enable BFD.

    OS10(config)# bfd enable

VTEP 2

  1. Configure the OSPF protocol in the underlay.

    OS10# configure terminal
    OS10(config)# router ospf 1
    OS10(config)# exit
    OS10(config)# interface ethernet 1/1/23:1
    OS10(config-if-eth1/1/23:1)# no switchport
    OS10(config-if-eth1/1/23:1)# ip ospf 1 area 0.0.0.0
    OS10(config-if-eth1/1/23:1)# exit
    
  2. Configure a Loopback interface.

    OS10(config)# interface loopback 1
    OS10(config-if-lo-1)# no shutdown
    OS10(config-if-lo-1)# ip address 202.0.0.1/32
    OS10(config-if-lo-1)# exit
    
  3. Create an NVE instance and configure a Loopback interface as the VXLAN source tunnel interface.

    OS10(config)# nve
    OS10(config-nve)# source-interface loopback 1
    
  4. Specify the NSX controller reachability information.

    OS10(config-nve)# controller ovsdb
    OS10(config-nve-ovsdb)# ip 10.16.140.182 port 6640 ssl
    OS10(config-nve-ovsdb)# max-backoff 10000
    OS10(config-nve-ovsdb)# exit
    
  5. Assign interfaces to be managed by the controller.

    OS10(config)# interface ethernet 1/1/25:3
    OS10(config-if-eth1/1/25:3)# switchport mode trunk
    OS10(config-if-eth1/1/25:3)# no switchport access vlan
    OS10(config-if-eth1/1/25:3)# nve-controller
    
  6. (Optional) Enable BFD.

    OS10(config)# bfd enable

Verify the controller configuration

To view controller-based information on the VTEP 1, use the show nve controller command.

OS10# show nve controller

Management IP            : 10.16.140.11/16
Gateway IP               : 200.0.0.1
Max Backoff              : 10000
Configured Controller    : 10.16.140.181:6640 ssl (connected)

Controller Cluster
IP                 Port     Protocol      Connected   State         Max-Backoff
10.16.140.182      6640     ssl           true        ACTIVE        10000
10.16.140.183      6640     ssl           true        ACTIVE        10000
10.16.140.181      6640     ssl           true        ACTIVE        10000

NVE Controller Ports
ethernet1/1/54:3

To display the VNID, port members, source interface, and remote VTEPs of the VXLAN, use the show virtual-network command.

OS10# show virtual-network
Codes: DP - MAC-learn Dataplane, CP - MAC-learn Controlplane, UUD - Unknown-Unicast-Drop
Virtual Network: 0
   Members:

Virtual Network: 6000
   Members:
      VLAN 20: ethernet1/1/54:3
   VxLAN Virtual Network Identifier: 6000
      Source Interface: loopback1(200.0.0.1)
      Remote-VTEPs (flood-list): 13.0.0.5(CP)

To view all the replicators and their status in the VXLAN, use the show nve replicators command.

OS10# show nve replicators
Codes: * - Active Replicator

BFD Status:Disabled
Replicators      State
-----------------------
13.0.0.5         Up
13.0.0.3         Up
13.0.0.2         Up

To view the remote VTEP status, use the show nve remote-vtep command.

OS10# show nve remote-vtep
IP Address: 13.0.0.2,  State: up, Encap: VxLAN
   VNI list: ,6000
IP Address: 13.0.0.3,  State: up, Encap: VxLAN
   VNI list: ,6000
IP Address: 13.0.0.5,  State: up, Encap: VxLAN
   VNI list: ,6000
IP Address: 202.0.0.1,  State: up, Encap: Vxlan
   VNI list: 6000

VTEP 2

OS10# show nve controller

Management IP            : 10.16.140.13/16
Gateway IP               : 202.0.0.1
Max Backoff              : 10000
Configured Controller    : 10.16.140.181:6640 ssl (connected)

Controller Cluster
IP                 Port     Protocol      Connected   State         Max-Backoff
10.16.140.182      6640     ssl           true        ACTIVE        10000
10.16.140.183      6640     ssl           true        ACTIVE        10000
10.16.140.181      6640     ssl           true        ACTIVE        10000

NVE Controller Ports
ethernet1/1/25:3

To display the VNID, port members, source interface, and remote VTEPs of the VXLAN, use the show virtual-network command.

OS10# show virtual-network
Codes: DP - MAC-learn Dataplane, CP - MAC-learn Controlplane, UUD - Unknown-Unicast-Drop
Virtual Network: 0
   Members:

Virtual Network: 6000
   Members:
      VLAN 20: ethernet1/1/25:3
   VxLAN Virtual Network Identifier: 6000
      Source Interface: loopback1(202.0.0.1)
      Remote-VTEPs (flood-list): 13.0.0.5(CP)

To view all the replicators and their status in the VXLAN, use the show nve replicators command.

OS10# show nve replicators
Codes: * - Active Replicator

BFD Status:Disabled
Replicators      State
-----------------------
13.0.0.5         Up
13.0.0.3         Up
13.0.0.2         Up

To view the remote VTEP status, use the show nve remote-vtep command.

OS10# show nve remote-vtep
IP Address: 13.0.0.2,  State: up, Encap: VxLAN
   VNI list: ,6000
IP Address: 13.0.0.3,  State: up, Encap: VxLAN
   VNI list: ,6000
IP Address: 13.0.0.5,  State: up, Encap: VxLAN
   VNI list: ,6000
IP Adress: 200.0.0.1,  State: up, Encap: Vxlan
   VNI list: 6000

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\