Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.1

PDF

Route leaking using route maps

You can leak routes in one VRF instance to another VRF instance using route maps.

To leak routes in one VRF instance using route maps:

  1. Enter the VRF from which you want to leak routes using route targets.
    CONFIGURATION
    ip vrf source-vrf-name
    ip vrf VRF-A
  2. Configure the IP prefix.
    CONFIGURATION
    ip prefix-list prefix-list-name {permit | deny} ip-address
    ip prefix-list abc permit 20.0.0.0/24
    or
    ip prefix-list abc deny 20.0.0.0/24
  3. Configure the route-map.
    CONFIGURATION
    route-map route-map-name
    route-map xyz
  4. Associate the prefix list to the route-map.
    CONFIGURATION
    route-map route-map-name {permit | deny} rule
    match ip address prefix-list prefix-list-name
    route-map xyz permit 10
    match ip address prefix-list abc
    or
    route-map xyz deny 10
    match ip address prefix-list abc
  5. Export the routes from a VRF instance using route maps.
    VRF CONFIGURATION
    ip route-export route-target route-map-name route-map-name
    ip route-export 1:1 route-map xyz
  6. Enter the destination VRf instance into which you want to leak the routes using route maps.
    CONFIGURATION
    ip vrf destination-vrf-name
    ip vrf VRF-B
  7. Import these leaked routes into another VRF instance.
    VRF CONFIGURATION
    ip route-import route-target
    ip route-import 1:1

Example Configuration for IPv4 static route leaking

OS10(config)#interface ethernet 1/1/1 
OS10(conf-if-eth1/1/1)# ip vrf forwarding VRF1 
OS10(conf-if-eth1/1/1)# ip address 120.0.0.1/24

OS10(config)#interface ethernet 1/1/2 
OS10(conf-if-eth1/1/2)# ip vrf forwarding VRF2 
OS10(conf-if-eth1/1/2)# ip address 140.0.0.1/24 
OS10(config)#ip route vrf VRF1 160.0.0.0/24 120.0.0.2
OS10(config)# ip vrf VRF1
OS10(conf-vrf)# ip route-export 1:1
OS10(config)# ip vrf VRF2
OS10(conf-vrf)# ip route-import 1:1

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\