NetWorker: Oracle-varmuuskopiointi epäonnistuu ja näyttää Lockbox-virheen kaikissa NetWorker-palvelimen vikatilanteissa

Summary: Kun NetWorker-klusterin palvelu siirtyy vikatilanteessa solmusta toiseen, Oracle-varmuuskopiointi epäonnistui ja näytti Lockbox-virheen

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ei muutoksia, mutta *@* näkyi NetWorker Server -asiakasresurssin Remote Access -kentässä

Ei Oracle-varmuuskopiointia. Ohjattu asiakastoiminto on poistettava tai sitä on muutettava, jotta RMAN-asetus saa varmuuskopioinnin toimimaan vikasietoisessa solmussa

NetWorker-klusteripalvelun vikatilanteessa Oracle-varmuuskopiointi epäonnistui ja näytti seuraavan virheen:

Oracle_Client:     Unable to obtain the user credentials from the lockbox due to the following error: 'Failed to open lockbox D:\nsr\lockbox\Oracle_Client\clb.lb'.Confirm that the user 'xyz' on the host 'Oracle_Client' is in the Users attribute of the lockbox resource.

Cause

NetWorker Server -resurssin Remote Access Field -kentässä (NetWorker Cluster -nimi) on *@*.
Jos Remote access -luettelossa on *@*, RAP DB:ssa ei ole tietoa, joka ilmoittaisi NetWorkerille, mikä toinen solmu on, ja NetWorker ei pysty valtuuttamaan kaikkia isäntiä (ja vaikka pystyisikin, NetWorker ei tekisi sitä, koska se olisi valtava tietoturva-aukko).  Aktiivisen solmun Lockbox on todennäköisesti luotu aktiivisessa solmussa ja passiivista solmua ei ole lisätty sallittujen luetteloon (sitä tarkoittaa virhe The system hostname key is missing).  Tämä Lockbox avautuu todennäköisesti normaalisti toisessa solmussa, ja sen luettelossa näkyy vain aktiivinen solmu.

Resolution

Lisätty seuraava NetWorker Server Resourcen (NetWorker-klusterin nimi) "Remote Access" -kenttään:

*@Physical_Node1
*@Physical_Node2

Tehtiin varmuuskopiointi, kaikki kunnossa. Molempien fyysisten solmujen tiedot päivittyivät oikein Lockbox-tietoihin.
Oracle-asiakasta ei tarvitse poistaa tai muuttaa

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000067776
Article Type: Solution
Last Modified: 03 May 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.