NVP-vProxy: Unable to register vProxy to NetWorker - SSL connect error / low level system api call failure

Summary: The NetWorker VMware Protection (NVP) integration is configured with the vProxy appliance. The vProxy encounters an error while trying to be registered to NetWorker through the NetWorker Management Console (NMC). ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker VMware Protection (NVP) integration is configured with the vProxy appliance. The vProxy encounters an error while trying to be registered to NetWorker through the NetWorker Management Console (NMC).
MM/DD/YYYY HH:MM:SS networkerserver.domain.com nsrdisp_vproxy NSR warning Received an SSL connect error from VPROXY "vproxy.domain.com" for URL "https://vproxy.domain.com:9090/api/v1/VproxyEngines", retrying request. 
MM/DD/YYYY HH:MM:SS networkerserver.domain.com nsrdisp_vproxy NSR info libCURL: function "curl_easy_perform" returned error 35: "An error occurred, a low level system api call failure" 
MM/DD/YYYY HH:MM:SS networkerserver.domain.com nsrmon NSR critical libCURL: function "curl_easy_perform" returned error 35: "An error occurred, a low level system api call failure" 

Cause

The NetWorker server cannot communicate with the vProxy over port 9090.  Ensure a network firewall or Router Intrusion Prevention System (IPS) software is not preventing the packets from reaching the vProxy.

Resolution

Ensure all ports listed in the Port Requirements section of the NetWorker VMware Integration Guide can communicate properly.  If required, capture a packet trace to validate the registration packets are properly flowing between the NetWorker Server and vProxy appliance.

NVP vProxy: Troubleshooting Network Connectivity For Backup and Restore Operations

You can debug the vrapid service on the vProxy appliance following: 
NetWorker VMware Protection (NVP)-vProxy: How to Enable Debug Logging

The vrapid-engine.log can be found on the vProxy under: /opt/emc/vproxy/runtime/logs/vrapid/
 
 

Additional Information

The following steps can be taken to capture a WireShark track dump during the vProxy registration. 
  • Capture the vProxy name and IP (example: vproxy.domain with IP xxx.xxx.16.83).
  • Capture the NetWorker Server name and IP (example: nwserver.domain with IP xxx.xxx.101.43).
  • On the NetWorker Server run Wireshark, add the vProxy filter: ip.addr == xxx.xxx.16.83 and start capturing packets.
  • On the vProxy appliance start a tcpdump: tcpdump -vvn -w /tmp/packet_dump.pcap
  • On the NetWorker Server, set debug level 9 for the nsrdisp_vproxy" process.
    • Windows cmd or Linux terminal: dbgcommand -p [nsrdisp_vproxy] debug=9
    • Windows Powershell: for /f "tokens=2 delims=," %F in ('tasklist /nh /fi "imagename eq nsrdisp_vproxy.exe" /fo csv') do dbgcommand -p %~F debug=9
  • Use nsradmin on the NetWorker server to unregister, and reregister the vProxy: NVP vProxy: How To Unregister/Re-Register a vProxy Appliance?
  • Wireshark should now show packets being sent/received from the vProxy IP.  Once the packets stop or after a few minutes
    • Stop the Wireshard trace on the NetWorker Server.
    • Cancel the tcpdump command from the vProxy Appliance.
  • On the NetWorker Server, set debug level 0 for the nsrdisp_vproxy" process.
    • Windows cmd or Linux terminal: dbgcommand -p [nsrdisp_vproxy] debug=0
    • Windows Powershell: for /f "tokens=2 delims=," %F in ('tasklist /nh /fi "imagename eq nsrdisp_vproxy.exe" /fo csv') do dbgcommand -p %~F debug=0
To evaluate the logs gather the following details:
  • The vProxy name, vProxy IP, NetWorker Server name, and NetWorker server IP.
  • The wireshark and vProxy tcpdump files.
  • The /opt/emc/vproxy/runtime/logs/vrapid/vrapid-engine.log file from the vProxy Appliance.
  • The rendered NetWorker server daemon.raw : nsr_render_log -S today daemon.raw > daemong_registeringvproxy.log 2>&1

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000036883
Article Type: Solution
Last Modified: 02 Nov 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.