DPA Commvault jobmonitor request fails with "Failed to connect to database server"
Summary: Data Protection Advisor (DPA) Commvault jobmonitor request fails with "Failed to connect to database server"
Symptoms
The Commvault jobmonitor request fails to connect to the CommServ database to collect job information.
The following errors were found in the dpaagent.log:
ERR 10924.7888 20190611:141003 sodbc.mssql.connect - cmssqlConnect(): SQLDriverConnect() failed: connect string was: DRIVER=SQL Server;SERVER=<server_name>\COMMVAULT;TRUSTED_CONNECTION=yes;DATABASE=CommServ;
ERR 10924.7888 20190611:141003 sodbc.mssql.sodbc - sodbcOpen(): Failed to connect to database server. server=<customer server name>\COMMVAULT, dbname=CommServ, user=, port=1512, flags=1. Error was: Record: 1, Status: 4060, State: 42000, Description: [Microsoft][ODBC SQL Server Driver][SQL Server]Cannot open database "CommServ" requested by the login. The login failed.(-1)
DBG1 10924.7888 20190611:141003 sodbc.mssql.connect - cmssqlClose(): Closing connection to SQL Server database. Server=<server_name>\COMMVAULT, DB=CommServ, Port=1512, Trusted=1, User=(null)
ERR 10924.7888 20190611:141003 agent.mod.cmv - jobmonitor(): failed to connect to CommServ database
Cause
The reason for the above error is that the user that is assigned to start the DPA agent process, does not have permissions to access the SQL database.
Resolution
The DPA Agent service must run with a named account if the CommVault SQL Server is using Windows authentication.
The named account chosen for the DPA Agent service must have permission for read access to the CommVault SQL Database.
The following rules apply:
1. SQL authentication with remote agent – Not Supported
2. SQL authentication with local agent - Not Supported
3. Windows authentication with remote agent - Not Supported
4. Windows authentication with local agent – Supported