PowerEdge: Running Dell System Update 2.0.0 for ESXi results in "Inventory file not found: inv.xml" error
Summary: Dell System Update (DSU) 2.0.0 for VMware ESXi fails with "Inventory file not found" error if the "--use-idrac-passthrough" option is not specified at launch.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The following error occurs during the inventory stage when running Dell System Update (DSU) 2.0.0 for VMware ESXi:
Inventory file not found - /scratch/opt/dell/dell_dup/inv.xml Progress report is available at:/scratch/opt/dell/dell_dup/DSU_STATUS.json Exiting DSU!
Cause
This is caused by DSU trying to run the Inventory Collector module which itself is not supported on VMware ESXi. DSU 2.0.0 for ESXi must always be run in "passthough" mode which collects firmware inventory directly from the iDRAC instead of the Inventory Collector module running on the operating system.
Resolution
When running any DSU method on a VMware ESXi host either in the local console, over SSH, or remotely from another DSU instance, always add the following command-line options:
--use-idrac-passthrough --source-type=REPOSITORY
Affected Products
Dell System Update, VMware ESXi 7.x, VMware ESXi 8.xProducts
C Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR ServersArticle Properties
Article Number: 000205742
Article Type: Solution
Last Modified: 21 Apr 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.