Microsoft App Agent - Determine if reboot is required
Summary: KB is for determining if upgrading or removing Microsoft App Agent will Require a reboot. This is typically caused when the Table Level Recovery option with Itempoint is enabled.
Symptoms
Uninstall or Upgrade of Microsoft App Agent with Table Level Recovery requires a reboot.
Cause
Due to the specific drivers which are installed with Table Level Recovery with Microsoft App Agent - Reboots may be required.
Resolution
Run an elevated PowerShell and run the following command, which returns specific values based on if itempoint is installed - Thus the server most likely require a reboot if uninstalled or during upgrade.(Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled'
Example:
PS C:\Users\administrator.AMER> (Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled' False PS C:\Users\administrator.AMER> (Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled' True
In summary, query the registry for that value within the path and if it exists it says True, else false -.
False = no reboot ideally - OS can still prompt reboot, but would not be based on Agent**.
True = reboot most likely required.
Additional Information