NetWorker: Block Based Backup (BBB) is failing with "The Data Domain Client Direct process could not obtain the password."
Summary: A NetWorker Block-Based Backup (BBB) or client-direct backup fails, stating that the remote user or password is incorrect.
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Symptoms
Client Direct Block Based Backups (BBB) failing to backup to DD with:
The Data Domain Client Direct process could not obtain the password.
DD device 'DEVICE_NAME' has no password set for DD connection.
98519:save: Unable to setup direct save with server NW_SERVER: CLIENT:SAVESET : Unable to perform backup for save-set ID 'SSID' with DIRECT_ACCESS=Yes, check device and pool configuration to enable Client direct..
90095:save: Cannot open save session with 'NW_SERVER':CLIENT:SAVESET : Unable to perform backup for save-set ID 'SSID' with DIRECT_ACCESS=Yes, check device and pool configuration to enable Client direct.
Client-side BBB save fails with:
Syntax: save -vvv -D3 -z -b POOL_NAME VOMULE_NAME(S)
Example: save -vvv -D3 -z -b ddbackups C:\ D:\ E:\
NOTE: "
-z" instructs the backup to run as BBB.
134490:save: Device is not configured for 'Client direct'.
12/29/17 10:50:52.147363 NsrBlockSave Failed.
12/29/17 10:50:52.147363 Initiating nsrblockbase returned failure for save set 'SAVESET'.
134491:save: Block based backup requires device properties to be configured for 'Client direct'. Please ensure a CIFS / NFS share is updated in the 'device access information' field along with 'remote user' and 'password'
90096:save: save of 'SAVESET' to 'NW_SERVER' failed: Block based backup requires device properties to be configured for 'Client direct'. Please ensure a CIFS / NFS share is updated in the
evice access information' field along with 'remote user' and 'password'
12/29/17 10:50:52.178563 CLIENT:SAVESET size 0 KB, 0 file(s), took 0 min 1 sec
134491:save: Block based backup requires device properties to be configured for 'Client direct'. Please ensure a CIFS / NFS share is updated in the 'device access information' field along with 'remote user' and 'password'
94693:save: The backup of save set 'SAVESET' failed.
NOTE: Though observed on a BBB backup, this issue relates to Client Direct and Data Domain, so it can affect any Client Direct backup.
Cause
ddboost user password is incorrect or must be reentered in the NetWorker device properties.
Resolution
1. Open the device properties and confirm that the ddboost user credentials are correct.
NOTE: The
ddpconnchk tool can be used to confirm ddboost connectivity from the NetWorker host reporting an issue: NetWorker: How to use the DDPCONNCHK tool to test DD ddboost connectivity from NetWorker Hosts
2. Unmount the device when no backups, clones, recoveries are using it.
3. Change the password field to any value and press OK.
4. Open the device properties again and reenter the correct password.
5. Remount the device and start the backup.
CAUTION: Do not label the device, if the device is labeled, all save sets are deleted.
Affected Products
NetWorkerProducts
NetWorker FamilyArticle Properties
Article Number: 000050159
Article Type: Solution
Last Modified: 24 Jun 2025
Version: 4
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