SourceOne Offline Access: Silent install is not populating SourceOne retrieval server details

Summary: Silent install is not populating SourceOne retrieval server details.

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Symptoms



Silent install is not populating SourceOne retrieval server details.

After running Offline Access silent install command as below (using CMD with administrator permissions):

ES1_OfflineAccess.exe /s /v"/qn /L*v C:\EMC_OfflineAccess.log INSTALLDIR=C:\Users\s1service\Downloads EX_TCP_PRIMARY_SERVER=Retrieval_SourceOne EX_TCP_PRIMARY_PORT=8001 EX_TCP_SECONDARY_SERVER=Retrieval_SourceOne EX_TCP_SECONDARY_PORT=8002 REBOOT=ReallySuppress "
 
The installation completes without any issue, although when reviewing the Offline Access Configuration settings, the Server Settings does not contain any details about SourceOne retrieval servers.

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Cause

The cause for the issue state above is related with lack of permissions over Windows folder. The user running the CMD only had Read permissions over C:\Windows.

E
ven the local administrator group members only had Read only permission.

The below entries can be found in a Procmon trace:

RegSvr32.exe 20812 CreateFileMapping C:\Windows\System32\regsvr32.exe FILE LOCKED WITH ONLY READERS SyncType: SyncTypeCreateSection, PageProtection: PAGE_EXECUTE|PAGE_NOCACHE




Resolution

When running a silent install for Offline Access, you must log-in to CMD using an account that has at least Read/Write permissions on folder C:\Windows.

Affected Products

SourceOne

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000063458
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  4
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