ECS: 컨테이너가 노드에서 영구적으로 중단되었습니다. 증상 코드: 2021년

Summary: 이 기술 자료 문서에서는 ECS가 노드에서 컨테이너가 영구적으로 중단되었다고 보고한 이유에 대해 설명합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

시스템에서 다음 알림과 함께 다이얼 홈을 호출했습니다.
Clarify Id: APMxxxxxxxx
Site Name: UNKNOWN
Vendor: EMC
DeviceType: ElasticCloudStorageApp
Model: ElasticCloudStorage
SerialNumber: APMxxxxxxxx
WWN: APMxxxxxxxx
Platform: platform
OS: SLES
OS_VER: 12.4
EmbedLevel: 2
InternalMaxSize: 512800
Comment: Fabric
Ucode_Ver: 3.7.0.6-7700.ed29023b
ConnectType: ESRS
IP_Address: Not Available
IP_Name: hostname.domainname.net
ConnectNum: 169.254.1.1
Port: 22

SymptomCode: 2021
Category: Status
Severity: Critical
Status: Failed
Component: Node
ComponentID: xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
SubComponent: Service
SubComponentID: <docker container name>
CallHome: true
FirstTime: 2023-12-09T07:48:20.232Z
Description: Container <container> is permanently down on node <node>

Cause

컨테이너가 최소 10분 동안 중지 또는 일시 중지되거나 전혀 시작되지 않았습니다.

Resolution

Docker 컨테이너(object-main, fabric-lifecycle, fabric-zookeeper, fabric-registry)가 중지 또는 일시 중지되었거나 최소 10분 동안 전혀 시작되지 않았습니다. 다음 절차에 따라 실패한 컨테이너를 확인합니다.
  1. 구성 요소 ID 또는 노드 ID를 기준으로 장애를 등록한 ECS 클러스터의 노드를 확인합니다. 예: 구성 요소 ID
4ca42022-46ed-475e-8ab7-6ef9141e5415
sudo /opt/emc/caspian/fabric/cli/bin/fcli lifecycle node.network --id 4ca42022-46ed-475e-8ab7-6ef9141e5415
{
  "network": {
    "hostname": "hostname.domainname.net",  << Hostname
    "private_ip": "169.254.1.3",       << NAN IP
    "mgmt_ip": "10.2.3.4",     << Management IP 
    "public_ip": "10.241.207.59",
    "data_ip": "10.241.207.73",
    "replication_ip": "10.241.207.59",
    "public_interface_name": "public",
    "private_interface_name": "private.4",
    "mgmt_interface_name": "public",
    "data_interface_name": "public:data",
    "replication_interface_name": "public"
  },
  "status": "OK",
  "etag": 50
}
  1.  관리 IP, 개인 IP 또는 호스트 이름을 사용하여 타겟 노드에 SSH를 수행합니다.
 
  1. Docker 서버가 적절한 매개변수로 작동하는지 확인합니다
# ps -ef | grep docker
root      50062      1  0 Jun02 ?        00:02:11 /usr/bin/docker daemon -H fd:// --insecure-registry=0.0.0.0/0 --log-level=warn
  1. 다음으로 어떤 컨테이너(NAMES 열)가 어떤 이유로 중지되었거나 전혀 시작되지 않았는지 확인해야 합니다(STATUS 열 참조).
# sudo docker ps -a
CONTAINER ID        IMAGE               COMMAND                  CREATED                STATUS              PORTS               NAMES
7bf16df0ef15        464b97154c24        "/opt/vipr/boot/boot."   3 days ago          Up 3 days                                    object-main
0ef5cc422543        24d9d6008893        "./boot.sh lifecycle"    3 days ago          Up 3 days                                    fabric-lifecycle
87d6c77d98ca        32cce433c3dc        "./boot.sh 3 1=169.25"   3 days ago          Up 3 days                                    fabric-zookeeper
  1. 패브릭 서비스가 실행 중인지 확인합니다. 패브릭 에이전트가 문제 컨테이너를 자동으로 재생성하려고 시도
# sudo service fabric-agent status
fabric-agent.service - fabric agent
   Loaded: loaded (/usr/lib/systemd/system/fabric-agent.service; enabled)
   Active: active (running) since Thu 2016-06-02 17:56:39 UTC; 3 days ago
  Process: 50643 ExecStartPre=/bin/rm -f /var/run/fabric-agent.pid (code=exited, status=0/SUCCESS)
 Main PID: 50645 (java)
   CGroup: /system.slice/fabric-agent.service
  1. 중지됨/실패한 컨테이너 상태 보기 
# sudo docker inspect fabric-zookeeper | grep -A12 State
    "State": {
        "Status": "running",
        "Running": true,
        "Paused": false,
        "Restarting": false,
        "OOMKilled": false,
        "Dead": false,
        "Pid": 80462,
        "ExitCode": 0,
        "Error": "",
        "StartedAt": "2016-06-06T17:29:12.968133861Z",
        "FinishedAt": "2016-06-06T17:29:12.882812946Z"
    },
 
여전히 문제가 있는지 확실하지 않은 경우 ECS 기술 지원에 문의하여 추가 지원을 받으십시오.

Affected Products

ECS Appliance Software without Encryption

Products

ECS Appliance, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption
Article Properties
Article Number: 000064491
Article Type: Solution
Last Modified: 17 Dec 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.