PowerStore: NDU Check "Failed in execution of preupgrade health check status of NAS subsystem"

Summary: NDU Pre-Upgrade Health Check (PUHC) fails when checking the status of the NAS subsystem.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Error code:
0xE0403001000C

Error message: Failed in execution of pre-upgrade health check status of NAS subsystem

Cause

When a PowerStore T appliance is running the NAS subsystem, additional NAS Health Checks are conducted during the NDU PUHC steps.

If any of the NAS health checks show a health status of less than 4 (4=Good), then the overall Health Check for the upgrade fails.

Job Details of the PUHC may show more than one Failed item. Check each Failed line by highlighting and viewing the details:
Job Details:

Description

Pre-Upgrade Health Check                            X Failed

Pre-upgrade health check failed on node A.   Please review the health check steps for more details (0xE0403001000C)

Health check - node A                               X Failed

Failed in execution of pre-upgrade health check status of NAS subsystem Check the alerts and events page for possible NAS errors and take corrective actions. (bsc_sdnas_puhc_executeStatusApi_error)

Resolution

The Job Details outlined in the Cause section may not offer enough clues to determine which NAS Health Check created the failure.
  1. To determine the cause of the failure, open an SSH session to your Cluster IP address and log in as the Service user. Ensure checking both nodes as the files may exist on either.
  2. Use the UNIX tool cat to view the following files, which provide more detail about the NAS issue. Use the complete path to the file in order to see the contents.
 
Note: When logged in as the service user, the current directory is /home/service/user.

 

/home/service/user
[SVC:service@xxxxxxx-A user]$ cat /var/log/sdnas/ansible/123.221.xxx.xxx_sdnas_deploy_error.json
{
"128.221.xxx.xxx": {
  "error_code": "\"1131\"",
  "error_description": "\"Health status of the cluster is not 4, cluster is not in a healthy state.\"",
  "error_recommended_action": "\"For PowerStore platform, please look at the file /var/log/sdnas/ansible/nas_health_events.log for more details regarding the health events. Please contact support for further assistance.\"",
  "failed_task": "Fail with a message if the health status of the cluster is not 4",
  "Date/Time": "2020-03-17/17:10:13",
  "failed_command": "",
  "failed_command_rc": "",
  "failed_command_stderr": "ERROR! The health status of cluster is 3. The cluster does not have the required health status of 4",
  "failed_command_stdout": "",
  "failed_node": "128.221.xxx.xxx"
}


}
[SVC:service@xxxxxxx-A user]$ cat /var/log/sdnas/ansible/nas_health_events.log
 Cluster health Status=3
 Event ID=5e71040c-0324-32ae-d4e4-56cb091ae676
 Event fullDescription=The DNS client is unable to connect to some of the configured DNS server however it is still operational.\n This may happen when the NAS server cannot reach the peer DNS server because of network problems.
 Event recommendedAction=Check the NAS server network interface and the router configuration.\n Or check the availability of the configured DNS server running the 'svc_cifssupport -checkup' or 'svc_nas -dns' command.
   Name=nasServer
   Value=smb160
 Event ID=5e710453-d4f8-4239-8b8e-5a3c89700de4
 Event fullDescription=The DNS client is unable to connect to some of the configured DNS server however it is still operational.\n This may happen when the NAS server cannot reach the peer DNS server because of network problems.
 Event recommendedAction=Check the NAS server network interface and the router configuration.\n Or check the availability of the configured DNS server running the 'svc_cifssupport -checkup' or 'svc_nas -dns' command.
   Name=nasServer
   Value=smb161
In the above example, one of the defined DNS Servers was not accessible, and after correcting that condition, the NDU Health Check passed.

Use the scripts svc_nas_tools and svc_nas_cifssupport to verify SDNAS in attempt to find the issue. See Dell PowerStore Service Scripts Guide to know more about the service scripts.

Example of checking the DNS Connectivity: 

[SVC:service@xxxxxx-B user]$ svc_nas_tools --server nas121 --args="-dns"
nas121 : commands processed: 1
output is complete

1597753629: LIB: 6: DNS is running.
1597753629: LIB: 6: DNS active config: override
1597753629: LIB: 6: * VDM Config: global
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: * VDM Config: local
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: * VDM Config: override
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: Dynamic DNS update exclude subnets:
1597753629: LIB: 6:   No subnet

Affected Products

PowerStore, PowerStore 1000T, PowerStore 3000T, PowerStore 5000T, PowerStore 7000T, PowerStore 9000T
Article Properties
Article Number: 000133035
Article Type: Solution
Last Modified: 06 Aug 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.