How to run the Online Diagnostics and use the Diagnostics for Troubleshooting

Summary: When your computer or Windows Tablet boots into Windows and connects to the Internet, you have several options to run diagnostics from the Dell Support Site.

Article Content


Symptoms

This covers the hardware that is installed on your computer; select the tabs below to find out more information.

Cause

 

When your computer or Windows Tablet boots into Windows and connects to the Internet, you have several options to run diagnostics from the Dell Support Site.

Note: Online Diagnostics supports Windows 8 and newer. For Windows 7 and under please refer to "Optimize and Maintain a Windows 7 Computer."

 

  • "Quick test" - This test of your hardware may take 10-15 minutes depending on the hardware in your system.
  • "Full Test" - This is an in-depth test. This may take 40 minutes or more depending on the hardware in your system.
  • Custom Component Test - Select one or more specific hardware tests you want to run.

    To run a specific test, perform the following steps.

    1. Browse to the "Dell Support" website.
    2. You are given three options to identify your computer.

      Either:

      • Touch or click the listing for your computer under THIS PC.
        Note: When there is no listing for your computer under THIS PC, you can touch or click Download & Install SupportAssist, which will automatically identify your computer for you. Follow the prompts to download and install SupportAssist.
      • Enter the Service Tag, Dell EMC Product ID, or Model, and then touch or click the Search button, and select your computer from the list.
      • Touch or click Browse all products: You must select the type of device you have, the brand name, and then the product model.
        Note: For more information refer to Dell Knowledge Base article, "How to Determine the Model Number of Your Dell Computer."
    3. Touch or click the DIAGNOSTICS tab.
    4. Under Custom Component Test, touch or click Select individual components.
    5. Touch or click to check the box next to one or more components you want to test.
    6. Touch or click the Run Your Test, and follow the prompts.


Refer to the Servers, Storage, and Networking support library for information about how to run the online diagnostics.

Note: When no issue is reported by the diagnostics, it means that no hardware issues were found. This most likely means you are having an issue with the Operating System on your computer.

Refer to the following resources for help with resolving performance issues and general troubleshooting information.

Resolution

 
Out of Warranty support  Out of warranty? No problem click here, enter your Service Tag and view our offers. 
 
Currently, offers are only available for US, Canada, UK, and France PC Customers. Server and Storage not applicable.

Article Properties


Last Published Date

13 Jan 2021

Version

2

Article Type

Solution

Rate This Article


Accurate
Useful
Easy to Understand
Was this article helpful?

0/3000 characters