How to Enter the Built-in Diagnostics (32-bit Diagnostics, SupportAssist ePSA, ePSA, and PSA)

Summary: Refer to each section that covers the hardware that is installed on your computer; select the tabs below to find out more information.

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Symptoms

Refer to each section on how to enter the diagnostics for your computer; select the tabs below to find out more information.

Note: Fo personal computers bought before Jan 1, 2009, please refer to the Older 32-Bit Diagnostics tab in the Dell Knowledge Base article Diagnostic tools for Dell PCs and Tablets.
Cause

 

 

SupportAssist ePSA, ePSA, and PSA diagnostics work on hard drives encrypted with Full Drive Encryption (FDE), without the need for a password. These diagnostics can also be performed on drives encrypted with BitLocker.

While it is true that the data on an encrypted drive is inaccessible, the diagnostic can access areas on the hard drive to test and store results.

If you receive errors while running the PSA or ePSA, SupportAssist ePSA diagnostic tests, please visit our ePSA online tool. You can get more information about possible resolutions to your issue and even get a part dispatched if needed.

 

  1. Tap the F12 key at the Dell splash screen on start-up.
 

 

  • Choose Diagnostics from the menu.

 

Notes:
  • When you are receiving a keyboard error or your keyboard is nonfunctional, connect an external keyboard from another computer so you can enter the built-in diagnostics.
  • The diagnostics on notebook systems are not meant to be run when the system is docked or the notebook is in a closed position. Doing this may result in a false error being reported.
  1. Perform one of the following button combinations during startup:
    • Hold in the Fn key and the power button.
    • Press the mute button while powering on (for Latitude E-series notebooks only).
    • Tap the F12 key at the Dell splash screen.
  2. Choose Diagnostics from the menu.

 

 

The pen can function at either the default calibration or at a custom-set calibration. It is recommended that you use the pen online while it is calibrated to your custom settings. Calibration optimizes pen performance for each user.

  1. Power on the system and immediately press the Volume Up button before the Dell Logo Splash screen is displayed. This accesses the Boot Menu.
  2. Either touch Diagnostics onscreen, or press the Volume Up button to move the pointer to Diagnostics.
  3. Press the Volume Down button to confirm your selection and start the ePSA utility.

 

 

For 11G and newer systems:

  1. Either tap the F10 key to enter the lifecycle controller, or tap F11 to enter the boot manager.
  2. Choose Diagnostics from the menu.

For 10G and older systems:

  1. Tap the F10 key to launch the Utility Mode (diags) option.
Notes:
Resolution

Refer to the following resources for help with resolving performance issues and general troubleshooting information.

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Last Published Date

21 Feb 2021

Version

5

Article Type

Solution

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