Data Protection Advisor: DPA: "could not execute batch" Error when Trying to Add a License

Summary: Error "could not execute batch" returned when trying to add a new license within the DPA UI.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The following error is observed when a user tries to add a license within the DPA UI:
Screenshot of message Error 500

Go to the following directory path on the DPA application server:
  • WINDOWS: Install Path: <Install Directory>\Services\Logs\server.log
  • UNIX: Install Path: <Install Directory>/dpa/services/logs/server.log
In the server log, the following error is observed:
2021-04-25 04:33:36,389 ERROR [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] (Thread-20599) Error
2021-04-25 04:33:36,389 ERROR [org.hibernate.engine.jdbc.batch.internal.BatchingBatch] (Thread-20599) HHH000315: Exception executing batch [could not execute batch]
2021-04-25 04:33:36,389 WARN  [com.arjuna.ats.arjuna] (Thread-20599) ARJUNA012125: TwoPhaseCoordinator.beforeCompletion - failed for SynchronizationImple< 0:ffff0a047c2a:-519e9284:607c0a4b:416c3d, org.hibernate.engine.transaction.synchronization.internal.RegisteredSynchronization@7d5820a7 >: javax.persistence.PersistenceException: org.hibernate.exception.GenericJDBCException: could not execute batch
.
Caused by: org.hibernate.exception.GenericJDBCException: could not execute batch
Further within the log, the following error is seen:
No space left on device
    Line 170582: Caused by: org.postgresql.util.PSQLException: ERROR: could not extend file "pg_tblspc/16390/PG_10_201707211/16385/22146": No space left on device

Cause

The DPA Datastore has no more disk space available preventing the addition of the license.

Resolution

Add additional disk space to the file system for the Datastore directory to allow the license to be entered in to the database.

The lack of disk space on the Datastore should be investigated to determine the cause and develop a resolution. 

Contact Dell Technical Support for further details or information.

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000185823
Article Type: Solution
Last Modified: 19 Feb 2025
Version:  4
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