NetWorker: runtime rendering (daemon.log) no longer works after NetWorker upgrade

Summary: Runtime rendering (daemon.log) no longer works after upgrade to NW 19.3.0.4

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

- Runtime rendering of no longer works after NW update
- Daemon log will no longer be updated

Cause

- NSR LOG has a large amount of suspicious entries under NSR LOG, like:

# nsradmin -p nsrexec
> p type:nsr log
...
..

type:nsr log
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: nsrpolicy;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log:;
    runtime rollover by size: Disabled;
    runtime rollover by time:;
                        name: Group_name.raw;
                    log path: /nsr/logs/migration/Group_name.raw;
...
..
.
OR
...
..
.
 type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-hMfdQc;
                    log path: /nsr/logs/adhoc/adhoc-job-hMfdQc;
...
.
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-9Q4xBr;
                    log path: /nsr/tmp/adhoc/adhoc-job-9Q4xBr;
...
..
.



- make sure only "mandatory" entries are under NSR LOG, like gstd, nsrim, nsrcpd, daemon

e.g.:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>

Resolution

- Make a copy of nsrladb
- Search for suspicious entries and remove them
- Entries can be "Adhoc" or "migration" (but other entries are possible):

- Delete those entries by using nsradmin (interactive mode) or via input file

e.g.
# vi del_adhoc
delete owner:Adhoc job log;

# nsradmin -p nsrexec -i del_adhoc
 

- Make sure only "mandatory" entries are under NSR LOG (e.g.: gstd, nsrim, nsrcpd, daemon)

e.g.:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>


- shutdown NW Server
- delete content under /nsr/tmp/

- start NW Server, runtime rendered log is now working

Affected Products

NetWorker
Article Properties
Article Number: 000186465
Article Type: Solution
Last Modified: 05 Aug 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.