NetWorker: runtime rendering (daemon.log) fungerar inte längre efter NetWorker-uppgradering

Summary: Runtime rendering (daemon.log) fungerar inte längre efter uppgradering till NW 19.3.0.4

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

– Runtime rendering of no longer works after NW update
- Daemon log will no longer be updated

Cause

– NSR-LOGGen har en stor mängd misstänkta poster i NSR-LOGGen, till exempel:

# nsradmin -p nsrexec
> p type:nsr log
...
..

typ: nsr-loggtyp:
NSR-logg;
               administratör: root, "user=nsrnmc,host=nw-server1.vlab.local",
"user=root,host=nw-server1.vlab.local";
                       ägare: nsrpolicy;
             maximal storlek MB: 2;
            maximala versioner: 10;
        exekörtid som gjorts logg:;
    runtime rollover efter storlek: Inaktiverad;
    runtime rollover by time:;
                        Namn: Group_name.raw;
                    loggsökväg: /nsr/logs/migration/Group_name.raw;
...
..
.
ELLER
...
.. .

typ: NSR-logg;
               administratör: root, "user=nsrnmc,host=nw-server1.vlab.local",
"user=root,host=nw-server1.vlab.local";
                       Ägare: Adhoc-jobblogg;
             maximal storlek MB: 2;
            maximala versioner: 10;
        körtid som tillhandahålls logg: ;
    runtime rollover efter storlek: Inaktiverad;
    runtime rollover by time: ;
                        namn: adhoc-job-hMfdQc;
                    loggsökväg: /nsr/logs/adhoc/adhoc-job-hMfdQc;
...
.
                        typ: NSR-logg;
               administratör: root, "user=nsrnmc,host=nw-server1.vlab.local",
"user=root,host=nw-server1.vlab.local";
                       Ägare: Adhoc-jobblogg;
             maximal storlek MB: 2;
            maximala versioner: 10;
        körtid som tillhandahålls logg: ;
    runtime rollover efter storlek: Inaktiverad;
    runtime rollover by time: ;
                        namn: adhoc-job-9Q4xBr;
                    loggsökväg: /nsr/tmp/adhoc/adhoc-job-9Q4xBr;
...
..
.



- Se till att endast obligatoriska poster finns i NSR LOG, som gstd, nsrim, nsrcpd, daemon

t.ex.
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
owner: nsrim;
                        namn: nsrim.raw;

                       Ägare: NetWorker;
                        namn: daemon.raw;

                       Ägare: NetWorker;
                        namn: nsrcpd.raw;

                       ägare: nsrdsa_recover;
                        namn: nsrdsa_recover.raw;

                       Ägare: NMC-loggens fuil;
                        namn: gstd.raw;

                       ägare: nsrdsa_save;
                        namn: nsrdsa_save.raw;
nsradmin>

Resolution

– Gör en kopia av nsrladb
– Sök efter misstänkta poster och ta bort dem –
posterna kan vara "Adhoc" eller "migration" (men andra poster är möjliga):

- Ta bort dessa poster med hjälp av nsradmin (interaktivt läge) eller via indatafil,

t.ex.
# vi del_adhoc delete
owner:Adhoc job log;

# nsradmin -p nsrexec -i del_adhoc


- Kontrollera att endast obligatoriska poster finns i NSR LOG (t.ex. gstd, nsrim, nsrcpd, daemon)

t.ex.:
# nsradmin -p nsrexec
nsradmin> visa namnet
nsradmin> p type:nsr log
owner: nsrim;
                        namn: nsrim.raw;

                       Ägare: NetWorker;
                        namn: daemon.raw;

                       Ägare: NetWorker;
                        namn: nsrcpd.raw;

                       ägare: nsrdsa_recover;
                        namn: nsrdsa_recover.raw;

                       Ägare: NMC-loggens fuil;
                        namn: gstd.raw;

                       ägare: nsrdsa_save;
                        namn: nsrdsa_save.raw;
nsradmin> –


shutdown NW Server
– ta bort innehåll under /nsr/tmp/

– starta NW-servern, loggen med körtid fungerar nu

Affected Products

NetWorker
Article Properties
Article Number: 000186465
Article Type: Solution
Last Modified: 05 Aug 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.