Dell EMC Networking OS10 Upon Login Log Message "syslog-ng.service is not active, cannot reload" Resolution

Summary: If you see the message "syslog-ng.service is not active, cannot reload" while logging in, follow this content for workaround and resolution.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When logging into the switch may see the following lines after logging into the switch:
 
syslog-ng.service is not active, cannot reload


Cause


In rare cases the /var/lib/syslog-ng/syslog-ng.persist may get corrupted. When this occurs, the syslog-ng service cannot start and will go into a failed state.

When you run the below command, you see the state as failed.

OS10# system "sudo systemctl status syslog-ng"
syslog-ng.service - System Logger Daemon
Loaded: loaded (/lib/systemd/system/syslog-ng.service; enabled; vendor preset: enabled)
Active: failed (Result: core-dump) since Tue 2021-10-01 11:58:22 UTC; 3 weeks

Resolution

Work Around



The failed syslog-ng.service can be started by deleting the /var/lib/syslog-ng/syslog-ng.persist file and starting the service.

Short term fix to restore service until scheduled upgrade-

OS10# system "sudo rm /var/lib/syslog-ng/syslog-ng.persist"
OS10# system "sudo systemctl start syslog-ng"
OS10# system "sudo systemctl status syslog-ng"

syslog-ng.service - System Logger Daemon
   Loaded: loaded (/lib/systemd/system/syslog-ng.service; enabled; vendor preset
   Active: active (running) since Thu 2021-10-28 22:05:58 UTC; 1min 35s ago


Resolution


Upgrade to 10.5.2.2 or a higher release for resolution.

Affected Products

SmartFabric OS10 Software
Article Properties
Article Number: 000193969
Article Type: Solution
Last Modified: 05 Jun 2025
Version:  3
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