PowerFlex 3.X: Backups may fail in version 3.8.0.8187 due to log4j remediation changes
Summary: Due to changes in the code for the log4j remediation in PowerFlex Manager 3.8.0.8187, backups may fail.
Symptoms
- Backups in PowerFlex Manager are failing.
- During the backup process, the /var/log location is filled up to 100%.
Cause
During PowerFlex Manager backups, the files are stored in a temporary location. This location changed in the 3.8.0.8187 version to a file system that does not have enough space for larger environments.
Resolution
Follow the steps below to apply the fix to resolve the backup failures in PowerFlex Manager:
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Download the PFxM_backup_fix_csp_en_US_1.zip file attached to this KB (The attached file is available only in the English version of the article).
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SSH to the PowerFlex Manager VM and sudo to root:
sudo su -
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Copy the PFxM_backup_fix_csp_en_US_1.zip file to /var/tmp on the PowerFlex Manager appliance using winscp or similar tool.
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Change to the /var/tmp directory:
cd /var/tmp
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Extract the copied file:
unzip PFxM_backup_fix_csp_en_US_1.zip
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Change the directory to the extracted location that has the run.sh file:
cd /var/tmp/PFxM_backup_fix_csp/
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Run the
run.shscript to apply the fix../run.sh