Avamar:無法流覽備份記錄「Client failed to respond to a request for its log.」
Summary: 嘗試流覽 Avamar 備份記錄失敗,並顯示「Client failed to respond a request for its log.」
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
嘗試在 Avamar UI 活動畫面流覽備份工作記錄時,作業會逾時。
「Activity Session Drill-Down」視窗會顯示「Session log is unavailable.」
錯誤是「Client failed to respond to a request for its log.」
執行作業並啟用偵錯時,avagent.log 會顯示下列內容:
如需詳細資訊,請參閱Avamar:如何收集記錄檔以進行 Avamar 用戶端備份與還原故障診斷問題
分頁沒有問題。用戶端可在 備份/還 原畫面中流覽 (Windows 檔案系統)。
「Activity Session Drill-Down」視窗會顯示「Session log is unavailable.」
錯誤是「Client failed to respond to a request for its log.」
執行作業並啟用偵錯時,avagent.log 會顯示下列內容:
如需詳細資訊,請參閱Avamar:如何收集記錄檔以進行 Avamar 用戶端備份與還原故障診斷問題
2018/05/31-17:12:33.04699 [agent_listenworker:33276:39:] agent_commands::browse_workorder timeout 9 seconds
2018/05/31-17:12:40.01300 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151-3006-SQL.alg'
2018/05/31-17:12:40.02500 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151-3006-SQL.log'
2018/05/31-17:12:40.03600 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151#1-3006-SQL.avtar.log'
2018/05/31-17:12:40.04800 [agent_listenworker:33276:39:] filecollector::find_files found 'Tlog_2000_15-SQL2012_2015_AlwaysOn_Tlog-1527725700151#0-3006-SQL.avtar.log'
2018/05/31-17:12:49.66599 [agent_listenworker:33276:39:] agent_commands::browse_workorder timed out
2018/05/31-17:12:49.66799 [agent_listenworker:33276:39:] agent_message::sendp server->isclosed:0, ssl:0, listenfirst_flag:1, listenfirst:0
2018/05/31-17:12:49.66899 [agent_listenworker:33276:39:] agent_message::sendp about to send xmlsize:127 filerefsize:125
2018/05/31-17:12:49.67100 [agent_listenworker:33276:39:] agent_message::sendp
分頁沒有問題。用戶端可在 備份/還 原畫面中流覽 (Windows 檔案系統)。
Cause
預設的流覽逾時回應時間為 10 秒。這不足以擷取大型記錄。
若要檢查目前的「流覽逾時」設定,請使用 SSH 以系統管理員身分登入 Avamar 伺服器並執行。
例如:
檢查設定:
若要檢查目前的「流覽逾時」設定,請使用 SSH 以系統管理員身分登入 Avamar 伺服器並執行。
mccli client show --name=
例如:
mccli client show --name=/clients/client-1.domain.com
檢查設定:
Browse Timeout 10 seconds
Resolution
- 將「流覽逾時」增加到 60 秒或更多。
重新開機用戶端上的「Backup Agent」服務。
mccli client edit --name=/clients/client-1.domain.com --timeout=60
重新開機用戶端上的「Backup Agent」服務。
Additional Information
若要在avagent.log 中啟用偵錯:
在用戶端上的 Avamar VAR 資料夾中建立avagent.cmd檔案。預設位置為 c:\Program Files\avs\var。
- 新增 --debug 至 avagent.cmd。
重新開機 Back Agent 服務。
在用戶端上的 Avamar VAR 資料夾中建立avagent.cmd檔案。預設位置為 c:\Program Files\avs\var。
- 新增 --debug 至 avagent.cmd。
重新開機 Back Agent 服務。
Affected Products
AvamarArticle Properties
Article Number: 000202240
Article Type: Solution
Last Modified: 20 Jul 2023
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.