Les sauvegardes d’Avamar Hyper-V échouent avec le message d’erreur « Error <43426> : La création d’un point de contrôle pour la machine virtuelle a échoué et sera ignorée de la sauvegarde . »

Summary: Les sauvegardes Avamar Hyper-V échouent ou se terminent avec des exceptions. Toutes les machines virtuelles d’un nœud Hyper-V spécifique sont exclues de la sauvegarde avec l’erreur suivante : « Erreur <43426>: La création d’un point de contrôle pour la machine virtuelle a échoué et sera ignorée de la sauvegarde. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Les sauvegardes Avamar Hyper-V échouent ou se terminent avec des exceptions. Toutes les machines virtuelles d’un nœud Hyper-V spécifique sont exclues de la sauvegarde avec l’erreur suivante : « Error  : La création d’un point de contrôle pour la machine virtuelle « » a échoué et sera ignorée de la sauvegarde.

Partie pertinente du log de sauvegarde :
avhypervvss Error : Checkpoint creation for Virtual machine '' has failed and will be skipped from backup. For details, please check 'winclustersvc.log'.
avhypervvss Error : Checkpoint creation for Virtual machine '' has failed and will be skipped from backup. For details, please check 'winclustersvc.log'.
.
.
.
avhypervvss Error : Checkpoint creation for Virtual machine '' has failed and will be skipped from backup. For details, please check 'winclustersvc.log'.
avhypervvss Info : --------------------Start [EMC Avamar Plug-in Service for Windows] log ----------

La partie correspondante dewinclustersvc.log se trouve dans le dossier C :\Program Files\avs\var\ sur le propriétaire de « EMC Avamar backup cluster client for ». Cela peut être déterminé à partir du gestionnaire de cluster de basculement. 

Pour que ces messages s’affichent, le débogage doit être activé sur le client dans winclustersvc. La section « Informations supplémentaires » de cet article explique comment activer le débogage.
winclustersvc WARN:  WMI API returned error: 'Failed to create checkpoint on collection 'AvamarBackup_-app-' ().
The operation failed.
Guest cluster validation on VM group 'AvamarBackup_-app-' () failed for checkpoint creation.
Size of the VM group 'AvamarBackup_-app-' () is not same with the size of the guest cluster.'  
winclustersvc DEBUG: : Retry '1', WMI API 'CreateSnapshot' for VMGroup 'AvamarBackup_-app-' 
winclustersvc DEBUG: ===> ValidateOutput  
winclustersvc DEBUG: WMI API return value is: '4096' 
winclustersvc DEBUG: Waiting for Job to complete... 
winclustersvc DEBUG: WMI job completed with status '10'  
winclustersvc WARN:  WMI API returned error: 'Failed to create checkpoint on collection 'AvamarBackup_-app-' ().
The operation failed.
Guest cluster validation on VM group 'AvamarBackup_-app-' () failed for checkpoint creation.

Cause

L’API Microsoft WMI génère ces messages lorsque plusieurs machines virtuelles sont sélectionnées à partir d’un nœud Hyper-V spécifique dans un Dataset de sauvegarde.

Resolution

Toutes les mises à jour récentes de Microsoft doivent être installées sur le nœud Hyper-V.

Aucune des machines virtuelles ne dispose d’un ensemble de disques, de disques partagés ou d’un CSV invité configuré. Il n’est pas pris en charge par la sauvegarde d’image Hyper-V.

Contournement:
  • Utilisez des groupes plus petits. 
  • Sélectionnez moins de machines virtuelles à partir d’un nœud spécifique dans le Dataset de sauvegarde.
  • Ouvrez un dossier auprès de Microsoft pour résoudre le problème d’API WMI sur le nœud Hyper-V.  

Additional Information

Pour activer le débogage dans winclustersvc :
  1. Utilisez le Bloc-notes pour créer winclustersvc.cmd dans le dossier C :\Program Files\avs\var\ sur le nœud Hyper-V, le propriétaire de « EMC Avamar backup cluster client for »
  2. Ajoutez --debug à celui-ci .
  3. Redémarrez « EMC Avamar Plug-in Service for Windows » sur le nœud Hyper-V. 
  4. Exécutez à nouveau la sauvegarde pour reproduire le problème.

Affected Products

Avamar
Article Properties
Article Number: 000206871
Article Type: Solution
Last Modified: 24 Jul 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.