VxRail : Sur la page des performances vSAN, l’erreur d’option des disques virtuels « Impossible d’interroger les données. Réessayez plus tard »
Summary: Pour une machine virtuelle individuelle, onglet Surveiller sur la page Performances de > vSAN, lorsque vous choisissez l’option Disques virtuels, le graphique ne parvient pas à se charger. Finalement, l’erreur « Impossible d’interroger les données. Réessayez plus tard. » ...
Symptoms
Les données de performances vSAN pour les disques virtuels individuels sur les machines virtuelles ne se chargent pas.
Une erreur finit par être renvoyée :
Unable to query data. Try again later

Les autres graphiques de performances VSAN (cluster, machine virtuelle, niveau de l’hôte ESXi, etc.) fonctionnent comme prévu.
Aucune erreur ou aucun avertissement correspondant sur le vSAN Intégrité
Skyline Lors de l’exécution de la commande ci-dessous sur certains hôtes, elle renvoie « rouge » pour les hôtes présentant des problèmes de connectivité.
esxcli vsan health cluster list Health Test Name Status -------------------------------------------------- ------ Overall health red (Network misconfiguration) Network red Hosts with connectivity issues red
Cause
Cela peut être dû à une incompatibilité de l’émetteur de certificat entre les hôtes VSAN.
Par exemple, cela se produit si un ou plusieurs hôtes ont vu leurs certificats remplacés après une mise à niveau de VxRail 4.7 vers VxRail 7 et versions ultérieures. Si VMCA émet les certificats, l’émetteur était le PSC avant la mise à niveau, et après la mise à niveau, l’émetteur est le vCenter (car PSC est désormais intégré).
Resolution
- Pour chaque hôte, cliquez sur Configurer>le certificat système>. Notez les détails de l’émetteur.
- Remplacez les certificats sur les hôtes ESXi dotés de certificats émis par PSC, afin que tous les certificats hôtes aient le même émetteur.
Par exemple, si VMCA émet les certificats (PSC ou vCenter) sur les hôtes qui disposent toujours de certificats émis par PSC, cliquez avec le bouton droit de la souris sur Host > Certificates >Renew Certificate.
- Cliquez avec le bouton droit de la souris sur Host > Certificates >Refresh CA Certificates