NetWorker: NetWorker DDBoost Yedekleme Aygıtlarında RPC Hataları

Summary: Etkin oturumlu Data Domain, Data Domain aygıtlarının eski bir duruma geçişine neden olan iletişim sorunlarını gözlemler. Yazma işlemi yoksa bile çalışmama oturumunu tutar ve ortam yönetimi veritabanından kullanılan oturum bilgilerini serbest bırakmaz. Aynı havuz ve depolama düğümüyle ilişkili tüm aygıtlar daha fazla oturumu kabulemiyor; etkilenen aygıtlar tarafından RPC hatalarının neden olduğu yedekleme veya klon işi kabul edilmemektedir. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • DDBOOST aygıtları Unmounted (Bağlantısız) durumunda olduğu için NetWorker Sunucusu üzerindeki tüm Yedekleme/Klon işlemleri Askıda/Kuyruğa alınma durumunda kalır ve Eylem günlüklerinde aşağıdaki hata görülür: 
Device ; RPC gönderme işlemi başarısız oldu; er ≥Kırık boru
 
  • Kurtarılamayan hatalar nedeniyle kaydetme kümesi yedeklemesi başarısız oldu. Önemli hata mesajlardan biri de bu.
  • NetWorker ve Data Domain arasında bağlantı sorunları olmasına rağmen Yedekleme penceresi sırasında Data Domain aygıtlarının bağlantısı kaldırılamıyor.
  • NetWorker İş Veritabanı'nın bozulması, NetWorker Yedekleme Uygulaması ile Jobs Veritabanı arasında tutarsızlıklara neden oluyor

Cause

Data Domain DDBOOST yedekleme aygıtlarında RPC Hataları düzenli olarak izlemeli ve düzeltici eylem gerçekleştirilecektir. Aksi takdirde Yedekleme/Klon İşleri bekleme durumunda kalır ve hatta yazma işlemi çalışmama oturumunu tutar ve ortam yönetimi veritabanından kullanılan oturum bilgilerini serbest bırakmaz.

Resolution

NetWorker Services yeniden başlatma işlemi ilk olarak yapılabilir ve DDBOOST aygıtlarında temel alınan RPC hataları hala devam ettiği için sorunun tekrar ortaya çıkar olduğunu fark edebiliriz. 

NetWorker Depolama düğümlerindeki Zaman Aşımı Değerleri, NetWorker Yedekleme ortamı hususları ve NetWorker aygıt optimizasyonu kılavuzuna göre ince ayara sahip olunmalıdır.

Bir Linux Ağ Depolama Düğümündeki uygun TCP Keep Alive Zaman Aşımı değerlerini gösterildiği gibi ayarlamak için aşağıdaki adımları izleyin.
1. Köke geçiş: sudo su -
2. Sistem ayarlarını değiştirmek için tcp_keepalive çalıştırın:
# echo 700 > /proc/sys/net/ipv4/tcp_keepalive_time
# echo 10 > /proc/sys/net/ipv4/tcp_keepalive_intvl
# echo 20 > /proc/sys/net/ipv4/tcp_keepalive_probes
Bir Windows Ağ Depolama Düğümündeki uygun TCP Keep Alive Zaman Aşımı değerlerini gösterildiği gibi ayarlamak için aşağıdaki adımları izleyin:
1. Değişiklik yapmadan önce Windows kayıt defterini yedekler.
2. "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters" yoluna gidin.
3. "KeepAliveTime" adlı yeni bir REG-DWORD girişi oluşturma.
4. Ondalık 900000 (15 dakika) değeri girin.
5. Yeni değerin etkin olması için yeniden başlatma gereklidir.

NOT: Ek TCP ayarı, sistem üzerinden sunulan NetWorker Performans Optimizasyonu Planlama Kılavuzu'https://www.dell.com/support/home/product-support/product/networker/docs.

Yukarıdaki parametreler tanımlanırken Depolama Düğümü NetWorker hizmetleri yeniden başlatılmalıdır. NetWorker depolama düğümü yeniden başlatıldığında bu değerlerin tutarlı kalmasını sağlar.

Ayrıca NetWorker depolama düğümündeki nsrmmd işlemiyle ilgili NetWorker Yedekleme Uygulamasındaki tüm tutarsızlıklar aşağıda belirtilen adımlar gerçekleştirilerek ortadan kaldırılmalıdır.

1. Yedekleme sunucusu üzerindeki NetWorker hizmetlerini durdurur.

Linux: nsr_shutdown
Windows: net stop nsrexecd /y

2. NetWorker Sunucusu üzerindeki /nsr/res/jobsdb, /nsr/logs/daemon.raw ve /nsr/tmp klasörlerini yeniden adlandırın.
3. NetWorker Hizmetlerini Yedekleme sunucusu üzerinde tekrar yeniden başlatın. Bu işlem, NetWorker kaydetme işlemlerine yeniden başlar ve başka RPC bağlantısı sıfırlaması ve çalışmama zaman aşımı değerleri farkedilmez.

Linux: systemctl start networker (Linux: systemctl ağ aygıtını başlat)
Windows: NMC
NetWorker sunucusuna yüklü ise net start nsrd
: net start gstd

Article Properties
Article Number: 000217738
Article Type: Solution
Last Modified: 15 Nov 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.