PowerStore: System Check detects drive invalid encryption band location for ENS24 enclosure

Summary: The System Check detects in a PowerStore 500T NVMe expansion enclosure (ENS24) drive invalid encryption band location. This checks if there is an issue with the band offset, which may result in locked drives following node reboot or power loss. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

If the System Check detects any NVMe expansion enclosure (ENS24) drives with incorrect band offset, one of the following error messages is displayed:

  • "<drive numbers> found with incorrect encryption band offset. (KB#000220624)"
    Drive(s) with incorrect encryption band configuration: <drive numbers> (KB#000220624
In the PowerStore Manager UI the issue detection appears as follows:
Image showing the PowerStore Manager Web UI Monitoring tab and the alerts described above in the article

If the service script svc_health_check is used to perform this health check, the output is as follows:
################# sample of incorrect Band 2 #####################################################
[BSC:cyc@ABCDEF-A ~]$ svc_health_check run -rhc indus_encryption_offset_check
/usr/lib/python2.7/site-packages/requests/__init__.py:91: RequestsDependencyWarning: urllib3 (1.26.5) or chardet (3.0.4) doesn't match a supported version!
  RequestsDependencyWarning)
Name                               Location  Status     Description
Indus Encryption Offset Check      node_a    Failed     BTLP8393024J7P6C BTLP8393026G7P6C BTLP905100AC7P6C BTLP8465037T7P6C BTLP8465040W7P6C found with incorrect encryption band offset. (KB#000220624)
 
 
SUMMARY Status: Failed
   Passed:      0
   Failed:      1
   Total:       1


################ sample of incorrect Band 1 and Band 3 ######################################################
 
[BSC:cyc@WXYZ-B ~]$  svc_health_check run -rhc indus_encryption_offset_check
Name                               Location  Status     Description
Indus Encryption Offset Check      node_a    Failed     Drive(s) with incorrect encryption band configuration: BTLP8393024J7P6C, BTLP8465040W7P6C, BTLP905100AC7P6C, BTLP8465037T7P6C, BTLP8393026G7P6C  (KB#000220624)
 
 
SUMMARY Status: Failed
   Passed:      0
   Failed:      1
   Total:       1


The PowerStore health check (PUHC) may fail the validation, with the following error: ENS24 enclosure drives have encryption bands incorrectly locked. The health check is an off-release PUHC check that is contained in the Health Check thin package.

Example screenshot for PUHC:

Image of the Pre Upgrade Health check in the PowerStore Manager Web UI presenting the errors described in the article
 
 

Cause

A software issue in adding an NVMe expansion enclosure (ENS24) on the 500T platform results in incorrect encryption bands configuration.
With this mis-configuration of encryption bands, the security service may not be able to unlock the drives. Appliance services may be unable to come up after a power outage or a dual node reboot.

This issue is resolved if NVMe expansion enclosures are added in PowerStoreOS 3.6 and later. For NVMe expansions added on a 500T prior to 3.6, contact technical support as soon as possible for the resolution be applied.  

Resolution

Contact technical support for assistance. Refer to this KB Article for expedited service.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000220624
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.