Connectrix Cisco: Trying to remove zones from Zoneset and received the error message "Status: Operation failed: [Error: Zone not present]"

Summary: The zone deletion for a VSAN is failing on a switch both from the Switch CLI and the Fabric Manager (DCNM SAN Client)

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Symptoms

The zone deletion for a VSAN is failing on a switch both from the Switch CLI and the Fabric Manager (DCNM SAN Client)
Trying to remove zones from Zoneset and receive the following error message:
Status: Operation failed: [Error: Zone not present]:
 

Cause


The Zone deletion was failing from both the Switch CLI and DCNM SAN Client because the Full Zone Database was missing on the switches.

Observe the below excerpt from the switch, the Full Zone Database (In-Active Config) has no zones, hence the value is "0" whereas the Active Zone Database (Active Config) has 11 zones in it.

Ideally when a zone is being deleted from a Zoneset, the operation is initiated from the Full Zone Database (Inactive Config). In this case, the Full Zone Database has no zones, due to which received the below alerts in the logs.

Excerpts from Switch CLI:
 

VSAN: 46 default-zone: Deny distributing: Full Interop: Default
    Mode: Enhanced merge-control: Allow
    Session:  None
    Single-session: Disabled
    Hard-zoning: Enabled broadcast: Unsupported
    Smart-zoning: Disabled
    Rscn-format: fabric-address
    Activation overwrite control: Disabled
Default zone:
    Qos: None broadcast: Unsupported ronly: Unsupported
Full Zoning Database:
    DB size: 184 bytes
    Zonesets:  1 Zones: 0 Aliases: 0 Attribute-groups: 1
Active Zoning Database:
    DB Size: 792 bytes
    Name: CISCO Zonesets: 1 Zones: 11
Current Total Zone database Usage: 976 / 4,000,000 bytes (0 % used)
Pending (Session) DB size:
    Full DB Copy size: 0 bytes
    Active DB Copy size: 0 bytes
SFC size: 0 / 4,000,000 bytes (0 % used)
Status: Operation failed: [Error: Zone not present]:
        At 15:15:32 SAST Jun 24 2024



Screenshot from DCNM:

Screenshot from DCNM

Resolution


Since there is inconsistency between the FULL and ACTIVE Zone database, suggest to first go ahead and copy the "Active zoneset to FULL zoneset" so that they are consistent across the concerned VSAN 46.
Post which the zone deletion should work.

Perform the below on the respective switch CLI:

#zone copy active-zoneset full-zoneset vsan 46


Once the Zone database (Full and Active) is consistent across the VSAN 46, then go ahead and try to remove the zones from DCNM (if needed) or the same can be performed from Switch CLI.

 

Affected Products

Connectrix MDS-Series Data Center Network Manager, Connectrix MDS-Series Firmware

Products

Connectrix MDS-Series Hardware
Article Properties
Article Number: 000227523
Article Type: Solution
Last Modified: 14 Apr 2025
Version:  2
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