PPDM: The database cannot be backed up, SQL Server FILESTREAM support is not enabled

Summary: Resolving PowerProtect Data Manager database backup failure with FILESTREAM functionality: Set FilestreamEffectiveLevel to 3, enable FILESTREAM for Transact-SQL access, and restart SQL Server service. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager Application Direct Protection policy completion with exceptions, SQL AlwaysOn Availability Group (AAG) database backup is skipped.

Protection policy logs show:
{"response":{"jobId":"Job_ID","status":"FAILURE","applicationInstances":[{"applicationInstance":"Instance_Name","status":"FAILURE","successfulSources":[],"failedSources":[],"skippedSources":[{"type":"database","name":"DB_Name","taskId":"task_Id","errorMessage":"The database cannot be backed up. Check the logs for more details.","status":"SKIPPED","errorCode":"","vendorSpecificErrorMessage":""}]
Enabling Troubleshooting:
  • ddbmsqlsv debug log shows:
SQL Server FILESTREAM support is not enabled for this instance. Database '<DB name>' is using FILESTREAM functionality and cannot be backed up.
Backup of FILESTREAM enabled database fails, backup of other databases that do not have FILESTEAM enabled are successful.

Cause

The FILESTREAM must be configured on the instance level.

Run the following queries to confirm the status:

SELECT convert(int, SERVERPROPERTY ('FilestreamEffectiveLevel'))
The output of the SELECT command returns FilestreamEffectiveLevel equal to 1 in customer setup.

For full access to file stream data, FilestreamEffectiveLevel must be 3 (3 means that T-SQL access, local and remote streaming access is allowed.)
SELECT COUNT * FROM master.sys.master_files AS mf WHERE mf.database_id = DB_ID(N'DBNAME') and mf.type = '2'
The output of the SELECT command returns 1 in customer setup, which means it is FILESTREAM data.

FilestreamEffectiveLevel of SQL server should be 3 to run the backup of this database, but it is set to 1. That is the reason backups are failing for this database.

 

Note: You can find these SELECT commands in the ddbmsqlsv.debug log.

Resolution

Enable FILESTREAM.

  1. On the Start menu, go to All Programs > SQL Server > Configuration Tools, and then select SQL Server Configuration Manager.

    Note: On newer versions of Windows, follow these instructions from Microsoft to open SQL Server Configuration Manager.This hyperlink is taking you to a website outside of Dell Technologies.
     
  2. In the list of services, right-click SQL Server Services, and then select Open.
  3. In the SQL Server Configuration Manager snap-in, locate the instance of SQL Server on which you want to enable FILESTREAM.
  4. Right-click the instance, and then select Properties.
  5. In the SQL Server Properties dialog box, select the FILESTREAM tab.
  6. Select the Enable FILESTREAM for Transact-SQL access check box.
  7. If you want to read and write FILESTREAM data from Windows, select Enable FILESTREAM for file I/O streaming access. Enter the name of the Windows share in the Windows Share Name box.
  8. If remote clients must access the FILESTREAM data that is stored on this share, select Allow remote clients to have streaming access to FILESTREAM data.
  9. Select Apply.
Note: Restart the SQL Server service.


See the Microsoft article Enable and configure FILESTREAM This hyperlink is taking you to a website outside of Dell Technologies. for more information.

Additional Information

See the Microsoft article Enable and configure FILESTREAM This hyperlink is taking you to a website outside of Dell Technologies. for more information.

Details of master.sys.master_files:
Details of master.sys.master_files
Figure 1: Details of master.sys.master_files

Affected Products

PowerProtect Data Manager, Microsoft App Agent
Article Properties
Article Number: 000227736
Article Type: Solution
Last Modified: 17 Jul 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.