OpenManage Enterprise: Cannot View Attributes When Editing Deployment Or Configuration Compliance Template
Summary: When editing a deployment template the 'Edit Components' screen is stuck with the 'Loading' animation. Also, when editing a compliance template the 'Template Details' screen is blank.
Symptoms
During the process of editing a deployment template, the 'Edit Components' screen is stuck with the 'Loading' animation.

While editing a compliance template, the Template Details screen is blank and shows no attributes.

Reviewing the tomcat application log (./tomcat/application.log) from the console log bundle (Monitor -> Troubleshoot -> Logs - Generate Log) shows a Number Format Exception error for the Templates Controller.
TemplatesController - com.google.gson.JsonSyntaxException: java.lang.NumberFormatException: Expected an int but was 2711473376 at line 1 column 1316 path $.AttributeGroups[0].SubAttributeGroups[0].SubAttributeGroups[0].Attributes[0].AttributeId com.google.gson.JsonSyntaxException: java.lang.NumberFormatException: Expected an int but was 2711473376 at line 1 column 1316 path $.AttributeGroups[0].SubAttributeGroups[0].SubAttributeGroups[0].Attributes[0].AttributeId
Cause
Each configuration attribute is stored individually in the database, and their IDs are called as standard integers. Standard integers use 32-bits of data, so they can only hold numbers up to 2 billion (-2.31 to +2.31). For any version of an OpenManage Enterprise instance that heavily uses deployment or configuration compliance templates, the attribute ID can exceed the standard integer dataset over time.
Resolution
A fix is in OpenManage Enterprise version 4.2.0 with a scheduled release date of October 2024.
Within this release the attribute ID calls is changed to a long integer.