NVP vProxy: VM backups fail with ERROR: HTTP Get request failed to download config file HTTP Status code: 404

Summary: When running backups of VMware Virtual Machines (VMs) using the NetWorker NVP-vProxy configuration, the backups all fail with errors trying to download the VM configuration file.

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Symptoms

NetWorker VMware Protection (NVP) VM backup session logs show the following error: 

YYYY-MM-DDTHH:MM:SS0Z ERROR: [80] HTTP Get request failed to download config file '[Datastore_name] VM_Name/VM_Name.vmx' using URL 'https://vcenter.server.name/folder/VM_Name/VM_Name.vmx?dcPath=Datacenter_name&dsName=Datastore_name'. [vcenter.server.name] HTTP Status code: 404.

vProxy backup sessions can be found in the following locations:

vProxy appliance: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE
NetWorker server Policy logs:

Linux: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME
Windows: C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME

NOTE: The policy log files on the NetWorker server are part of the jobsdb retention policy. The default retention policy is 72 hours. This means any log files older than the retention window are removed. Session log files on the vProxy appliance are not removed by the jobsdb retention policy.

Cause

This error occurs due to a known configuration issue in the VMware vpxd.conf file. 

Resolution

A resolution to this issue can be found in the following VMware KB 326221: 
Unable to access the vCenter landing page for vCSA 6.x/7.x/8.x This hyperlink is taking you to a website outside of Dell Technologies.

NOTE: The VMware vCenter Administrator must perform any changes required on the vCenter.

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000302526
Article Type: Solution
Last Modified: 01 Apr 2025
Version:  1
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