PowerStore: Pre-upgrade health check (PUHC) to detect 4.0.X metro system with SYM metro volumes stuck in sync DB status
Summary: During a non-disruptive upgrade (NDU) from PowerStoreOS 3.X to 4.0.X, cluster components responsible for managing Metro volumes may become stuck in a synchronization (sync DB) state. Exposure to this issue does not immediately cause impact on the storage environment however it is likely to eventually manifest I/O errors, latency spikes, or unexpected HA events potentially resulting in temporary data access issues. This pre-Upgrade Health Check (PUHC) is designed to identify this condition and provide guidance as needed before an NDU to PowerStoreOS 4.1. ...
Symptoms
If the PUHC detects one or more metro volumes stuck in a "sync DB", the PowerStore Manager GUI displays:

Impact
While this condition does not immediately affect host-level connectivity, it can eventually lead to performance and availability issues if left unresolved.
Potential impacts include:
- I/O errors
- Latency spikes
- Unexpected high availability (HA) events
- Temporary host-side data unavailability (DU)
If the issue is carried forward into a subsequent upgrade, resolution may require manual intervention, increasing operational complexity and potentially impacting system availability.
Cause
PowerStore 4.0 introduced an internal synchronization mechanism to support SCSI-3 persistent reservations for Metro volumes. However, a potential deadlock or race condition during the synchronization process may cause a metro volume to remain stuck in a sync_db mode.
Resolution
A permanent fix to this issue is targeted to be released in PowerStoreOS version 4.1.0.3
Workaround:
In the presence or absence of impacting symptoms, but before an NDU is started, this issue can be remediated with the following steps
- Use the PowerStore Manager GUI to pause and resume all Metro sessions in small bulks from one side of the metro configuration. This action prompts the PowerStore to re-align the metro volume state. Please note that there is no need to pause/resume from both sides of the metro configuration.
- From PowerStore Manager (GUI) run PUHC again to confirm that issue is resolved
Please contact technical support if symptoms persist.
Additional Considerations:
If an NDU has already been started, it is possible that systems may be impacted due to this issue. Please refer to KB 000328976 - PowerStore: upgrade to PowerStoreOS v4.1 may result in DU for metro volume configurations for additional information.