Avamar 19.7/19.8 Kan geen back-upcontent ophalen wanneer DD-certificaatverificatie mislukt of is uitgeschakeld

Resumen: Avamar 19.7/19.8 7: Kan geen back-upcontent ophalen wanneer verificatie van DD-certificaten mislukt of is uitgeschakeld.

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

In Avamar 19.7/19.8 worden back-ups op Data Domain mogelijk niet vermeld of hersteld en zien we de volgende fouten in AUI.

Avamar back-uplijst 
In de details van de weergave wordt deze aanvullende informatie weergegeven: 

Details van het evenement



Tabblad Inhoud terugzetten
 
 

Causa

In Avamar 19.7/19.8 probeert MCS zich standaard aan te melden bij DD met certificaatverificatie bij het bladeren naar back-ups in Data Domain. In sommige omgevingen kan deze DD-aanmelding mislukken.  

Om te bevestigen dat deze DD-aanmelding mislukt, controleert u de volgende logboeklocatie:
/usr/local/avamar/var/mc/server_log/mcserver.log.0 

In mcserver.log.0 zien we de volgende fout die aangeeft dat in deze omgeving deze DDR-aanmelding mislukt. 
FINE: exec avtar 1 : exit code: '170: /usr/local/avamar/bin/avtar --showlog --noinfo --seq=1 --path=vc.example.com/vm1_Esks0jsQM6ei34MQsDyBFw workorder --id=MCUser --ap=******* --hfsaddr=ave --hfsport=27000 --conntimeout=120 --ddr-auth-enabled=true --ddr-auth-mode=2 --vardir=/usr/local/avamar/var ' elapsed time: 1310ms
[RMI TCP Connection(1385)-ave#39854] com.avamar.mc.util.MCException.logException
WARNING: java.io.IOException: avtar Warning : Calling DDR_OPEN returned result code:5049 message:file not found
avtar Error : Data Domain server "ddve.example.com" open failed DDR result code: 5049, desc: file not found
avtar Error : Problem logging into the DDR server index:1

  at com.avamar.mc.dpn.AvtarCmd.execAvtar(AvtarCmd.java:223)
  at com.avamar.mc.dpn.DPNProxyService.getVmBackupConfig(DPNProxyService.java:6033)
  at com.avamar.mc.burm.BackupRestoreManagerService.getVmBackupConfig(BackupRestoreManagerService.java:3064)
  at sun.reflect.GeneratedMethodAccessor246.invoke(Unknown Source)

Resolución

Dit probleem wordt onderzocht door Avamar Engineering. 

Om dit probleem met de back-uplijst op te lossen, kunnen we een van de volgende tijdelijke oplossingen uitvoeren:

Stappen:
1. Voer de volgende opdracht uit op de Avamar-server. 
admin@ave197:~/>: grep secure_dd /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml
Voorbeeld van uitvoer 1 (uitgeschakeld)
 
Voorbeeld van uitvoer 2 (ingeschakeld)
 
  


Tijdelijke oplossing 1:  Als de uitvoer 'false'weergeeft, gaat u naar stap 2. Als de uitvoer waar is, gaat u naar stap 3. 

2.  Maak als root een back-up van de /usr/local/avamar/bin/avtar:

cp -p /usr/local/avamar/bin/avtar /usr/local/avamar/bin/x-avtar.`date -I`


Bewerk vervolgens het bestand /usr/local/avamar/bin/avtar en wijzig de onderkant van het bestand in het volgende:
BEFORE

# Must 'exec' executable so that kills sent to this pid (such as from rununtil) work
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@"
NA  
# Must 'exec' executable so that kills sent to this pid (such as from rununtil) work
if [[ "$*" == *--ddr-auth-enabled=true* ]]
then
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@" --ddr-auth-mode=3 --ddr-auth-enable=false
else
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@"
fi
 Dit zou het probleem met de lijst moeten oplossen en u kunt hier stoppen!

Tijdelijke oplossing 2
3.  Als secure_dd_feature_on waar is, gebruikt u de volgende stappen.  
admin@ave197:~/>: openssl x509 -in /home/admin/chain.pem -noout -fingerprint
SHA1 Fingerprint=81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D6
4. Verkrijg de gebruikersnaam en hostnaam voor een of meer datadomeinen die VM-back-up bevatten met behulp van de ddrmaint-opdracht.
admin@ave197:~/>: ddrmaint read-ddr-info --format=full
====================== Read-DDR-Info ======================

 System name        : ddve.example.com
 System ID          : EXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 DDBoost user       : ddboost 
OPMERKING: Als er meer dan één Data Domain is toegevoegd aan Avamar, herhaalt u de stappen 5-7 op elke vermelde DD.

5. Voer deze ssh-opdracht uit naar de DD om te controleren of de SHA1-vingerafdruk naar DD is geüpload. 
admin@ave197:~/>: ssh ddboost@ddve.example.com  -i /usr/local/avamar/lib/ddr_key   "adminaccess certificate show imported-ca"| grep -c 

Voorbeeld van een gezonde uitvoer: 
admin@ave197:~/>:  ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate show " | grep -c 81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D6 
EMC Data Domain Virtual Edition
1
Voorbeeld van een slechte uitvoer: 
 ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate show " | grep -c 81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D6 
EMC Data Domain Virtual Edition
0

6. Als het certificaat NIET aanwezig is, voert u de volgende opdracht uit om het certificaat te importeren.
admin@ave197:~/>: cat chain.pem | ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate import ca application ddboost"     
7. Start vervolgens ddboost opnieuw op. 
ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "ddboost disable " 
ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "ddboost enable"

Dit zou het probleem met de vermelding moeten oplossen. Als het probleem niet is opgelost, implementeert u tijdelijke oplossing 1 en neemt u contact op met Dell Support. 

Productos afectados

Avamar, Avamar Server
Propiedades del artículo
Número de artículo: 000203335
Tipo de artículo: Solution
Última modificación: 10 ago 2023
Versión:  12
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.