Avamar 19.7/19.8 Não é possível recuperar o conteúdo de backup quando a autenticação de certificado do DD apresenta falha ou está desabilitada
Resumen: Avamar 19.7/19.8 7: Não é possível recuperar o conteúdo de backup quando a autenticação de certificado do DD está falhando ou desabilitada.
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Síntomas
No Avamar 19.7/19.8, os backups no Data Domain podem não ser listados ou restaurados, e vemos os seguintes erros na AUI.
Os detalhes da visualização mostram essas informações adicionais:
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Causa
No Avamar 19.7/19.8, o MCS tenta fazer log-in no DD com autenticação de certificado por padrão ao procurar backups no Data Domain. Em alguns ambientes, esse log-in do DD pode falhar.
Para confirmar se esse log-in do DD está falhando, verifique o seguinte local de registro:
No mcserver.log.0, vemos o seguinte erro indicando que, neste ambiente, esse log-in do DDR está falhando.
Para confirmar se esse log-in do DD está falhando, verifique o seguinte local de registro:
/usr/local/avamar/var/mc/server_log/mcserver.log.0
No mcserver.log.0, vemos o seguinte erro indicando que, neste ambiente, esse log-in do DDR está falhando.
FINE: exec avtar 1 : exit code: '170: /usr/local/avamar/bin/avtar --showlog --noinfo --seq=1 --path=vc.example.com/vm1_Esks0jsQM6ei34MQsDyBFw workorder --id=MCUser --ap=******* --hfsaddr=ave --hfsport=27000 --conntimeout=120 --ddr-auth-enabled=true --ddr-auth-mode=2 --vardir=/usr/local/avamar/var ' elapsed time: 1310ms [RMI TCP Connection(1385)-ave#39854] com.avamar.mc.util.MCException.logException WARNING: java.io.IOException: avtar Warning : Calling DDR_OPEN returned result code:5049 message:file not found avtar Error : Data Domain server "ddve.example.com" open failed DDR result code: 5049, desc: file not found avtar Error : Problem logging into the DDR server index:1 at com.avamar.mc.dpn.AvtarCmd.execAvtar(AvtarCmd.java:223) at com.avamar.mc.dpn.DPNProxyService.getVmBackupConfig(DPNProxyService.java:6033) at com.avamar.mc.burm.BackupRestoreManagerService.getVmBackupConfig(BackupRestoreManagerService.java:3064) at sun.reflect.GeneratedMethodAccessor246.invoke(Unknown Source)
Resolución
Esse problema está sendo investigado pela equipe de engenharia do Avamar.
Para resolver esse problema de listagem de backup, podemos fazer uma das seguintes soluções temporárias:
Etapas:
1. Execute o seguinte comando no Avamar Server.
Solução temporária 2
3. Se secure_dd_feature_on for verdadeiro, siga as etapas a seguir.
5. Execute o comando ssh a seguir no DD para verificar se a impressão digital SHA1 foi carregada no DD.
Exemplo de saída íntegra:
6. Se o certificado NÃO estiver presente, faça o seguinte comando para importar o certificado.
Isso deve resolver o problema de listagem. Se o problema não for resolvido, implemente a solução temporária 1 e entre em contato com o suporte da Dell.
Para resolver esse problema de listagem de backup, podemos fazer uma das seguintes soluções temporárias:
Etapas:
1. Execute o seguinte comando no Avamar Server.
admin@ave197:~/>: grep secure_dd /usr/local/avamar/var/mc/server_data/prefs/mcserver.xmlExemplo de resultado 1 (desabilitado)
Exemplo de resultado 2 (ativado)
Solução alternativa 1: Se a saída mostrar "false",vá para a etapa 2. Se o resultado for verdadeiro, vá para a etapa 3.
2. Como root, faça backup do /usr/local/avamar/bin/avtar:
cp -p /usr/local/avamar/bin/avtar /usr/local/avamar/bin/x-avtar.`date -I`
Em seguida, edite o arquivo /usr/local/avamar/bin/avtar e altere a parte inferior do arquivo para o seguinte:
BEFORE
# Must 'exec' executable so that kills sent to this pid (such as from rununtil) work
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@"
DEPOIS
# Must 'exec' executable so that kills sent to this pid (such as from rununtil) work
if [[ "$*" == *--ddr-auth-enabled=true* ]]
then
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@" --ddr-auth-mode=3 --ddr-auth-enable=false
else
exec ${BASEDIR}/bin/avtar.bin $platform_flags --vardir="${BASEDIR}/var" --bindir="${BASEDIR}/bin" --sysdir="${BASEDIR}/etc" "$@"
fi
Isso deve resolver o problema de listagem e você pode parar aqui!
Solução temporária 2
3. Se secure_dd_feature_on for verdadeiro, siga as etapas a seguir.
admin@ave197:~/>: openssl x509 -in /home/admin/chain.pem -noout -fingerprint SHA1 Fingerprint=81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D64. Obtenha o nome de usuário e o hostname de um ou mais data domains que contenha backup de VM usando o comando ddrmaint.
admin@ave197:~/>: ddrmaint read-ddr-info --format=full ====================== Read-DDR-Info ====================== System name : ddve.example.com System ID : EXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX DDBoost user : ddboost
Nota: Se mais de um Data Domain for adicionado ao Avamar, repita as etapas de 5 a 7 em cada DD listado.
5. Execute o comando ssh a seguir no DD para verificar se a impressão digital SHA1 foi carregada no DD.
admin@ave197:~/>: ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate show imported-ca"| grep -c
Exemplo de saída íntegra:
admin@ave197:~/>: ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate show " | grep -c 81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D6 EMC Data Domain Virtual Edition 1Exemplo de saída não ínte em boas condições:
ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate show " | grep -c 81:E0:5B:F4:55:E0:0F:0A:E9:5B:BE:71:40:31:DB:55:B0:0C:6F:D6 EMC Data Domain Virtual Edition 0
6. Se o certificado NÃO estiver presente, faça o seguinte comando para importar o certificado.
admin@ave197:~/>: cat chain.pem | ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "adminaccess certificate import ca application ddboost"7. Em seguida, reinicie o ddboost.
ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "ddboost disable " ssh ddboost@ddve.example.com -i /usr/local/avamar/lib/ddr_key "ddboost enable"
Isso deve resolver o problema de listagem. Se o problema não for resolvido, implemente a solução temporária 1 e entre em contato com o suporte da Dell.
Productos afectados
Avamar, Avamar ServerPropiedades del artículo
Número de artículo: 000203335
Tipo de artículo: Solution
Última modificación: 10 ago 2023
Versión: 12
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