NVP-vProxy: VM-Backup schlägt fehl mit "Snapshot has already been deleted or has not been completely created" (Snapshot wurde bereits gelöscht oder wurde nicht vollständig erstellt)
Sommaire: VM-Backup schlägt fehl mit "Snapshot has already been deleted or has not been completely created" (Snapshot wurde bereits gelöscht oder wurde nicht vollständig erstellt)
Cet article s’applique à
Cet article ne s’applique pas à
Cet article n’est lié à aucun produit spécifique.
Toutes les versions de produits ne sont pas identifiées dans cet article.
Symptômes
- VM-Backups, die mit der NVP vProxy-Appliance durchgeführt wurden, melden den folgenden Fehler:
YYYY-MM-DDTHH:mm:SSZ ERROR: Request to remove snapshot 'snapshot-#####' on VM 'VM_NAME' was rejected by vCenter 'VCENTER_NAME': ServerFaultCode: The object 'vim.vm.Snapshot:snapshot-#####' has already been deleted or has not been completely created
Cause
Es gab alte Snapshot-Dateien im Datenspeicher für diese VM.
Résolution
Das ProxyHC-Dienstprogramm kann verwendet werden, um übrige Festplatten und Snapshots zu bereinigen.
Um eine manuelle Bereinigung in VMware durchzuführen, führen Sie die folgenden Schritte aus:
Zu Beginn der VM-Backups fordert der vProxy das vCenter auf, einen Snapshot für die VM zu erstellen. Am Ende des Backups wird eine Anforderung zum Entfernen des Snapshot gesendet. Der vCenter-Server erstellt, managt und löscht die Snapshot-Dateien. Wenn dieses Problem weiterhin besteht oder während eines der oben genannten Schritte ein Fehler auftritt, wenden Sie sich an den VMware-Support, um Unterstützung zu erhalten.
Um eine manuelle Bereinigung in VMware durchzuführen, führen Sie die folgenden Schritte aus:
- Melden Sie sich beim vSphere-Webclient an.
- Klicken Sie mit der rechten Maustaste auf die VM und wählen Sie Snapshots –> Alle Snapshots löschen aus.
- Klicken Sie mit der rechten Maustaste auf die VM und wählen Sie Snapshots-Consolidate> aus.
- Wählen Sie die Registerkarte Datastores aus und navigieren Sie zum Verzeichnis für die VM und suchen Sie nach Snapshot-Dateien. Wenn sich Snapshot-Dateien hier befinden, löschen Sie sie.
- Wenn keine Snapshots gefunden werden, aber das Problem weiterhin besteht, versuchen Sie, einen Snapshot von VMware zu erstellen.
HINWEIS:Wenn die VM anwendungskonsistente Backups (MSVMAPPAGENT) durchführt, führen Sie einen stillgelegten Snapshot aus. Andernfalls führen Sie einen nicht stillgelegten Snapshot durch.
- Wiederholen Sie die Schritte 2 bis 4, um sicherzustellen, dass die Snapshot-Dateien entfernt werden.
- Führen Sie ein Backup aus.
Zu Beginn der VM-Backups fordert der vProxy das vCenter auf, einen Snapshot für die VM zu erstellen. Am Ende des Backups wird eine Anforderung zum Entfernen des Snapshot gesendet. Der vCenter-Server erstellt, managt und löscht die Snapshot-Dateien. Wenn dieses Problem weiterhin besteht oder während eines der oben genannten Schritte ein Fehler auftritt, wenden Sie sich an den VMware-Support, um Unterstützung zu erhalten.
Produits touchés
NetWorkerProduits
NetWorkerPropriétés de l’article
Numéro d’article: 000172495
Type d’article: Solution
Dernière modification: 28 mai 2025
Version: 4
Obtenez des réponses à vos questions auprès d’autre utilisateurs de Dell
Services de soutien
Vérifiez si votre appareil est couvert par les services de soutien.