Avamar: Proxy Management Proxy Status FEIL: "Proxy er utilgjengelig. Sjekk nettverksinnstillingene"
概要: I Avamar HMTL5 Administrator-brukergrensesnittet rapporterer Proxy-statusmenyen under Proxybehandling en feil som sier "Proxy kan ikke nås. Sjekk nettverksinnstillingene." Til tross for dette godtar proxyen sikkerhetskopierings- og gjenopprettingsjobber, og Avamar-serveren kan nå proxyen på alle standard påkrevde TCP-porter som dokumentert. ...
現象
Avamar rapporterer en feil i Proxy-statusmenyen for Avamar HTML5 Administrator UI (AUI) Proxy Management > . Til tross for denne feilen godtar proxyen sikkerhetskopierings- og gjenopprettingsjobber, og Avamar-serveren kan nå den på alle standard TCP-porter.
原因
Avamar Proxy Deployment Manager (PDM) bruker en enkel TCP-synkronisering til port 7 (xinetd echo) for å bekrefte at proxyens IP-adresse er ledig under distribusjonen (for å unngå IP-konflikter) og for å bekrefte at proxyen er i drift. Denne kontrollen utføres før du starter en mer omfattende tilkobling til vami-sfcb-tjenesten for å bekrefte statusen til kritiske tjenester (Jetty, vami-sfcb, Avagent, vmwareflr, vmtools).
Denne eldre serviceporten brukes vanligvis ikke, og proxyen svarer på TCP-synkroniseringen med en tilbakestilling. I miljøer der en brannmur fjerner synkroniseringspakken, rapporterer imidlertid funksjonen PDM-proxystatus at proxyen ikke kan nås.
解決方法
Denne virkemåten er forventet og angir at brannmuren slipper TCP-synkroniseringspakken på port 7. Hvis du vil løse dette problemet, bør du vurdere følgende alternativer:
-
Tillat trafikk på TCP-port 7: Endre de eksterne brannmurreglene for å tillate trafikk fra TCP-port 7, slik at Avamar-proxyen kan sende sin egen forespørsel om tilbakestilling. Dette sikrer at proxy-statuskontrollen rapporterer riktig.
-
Konfigurer brannmuren til å avvise trafikk fra TCP-port 7: I stedet for å slippe pakkene, konfigurerer du brannmuren til å avvise trafikk på TCP-port 7. Vær oppmerksom på at avvisning av trafikk på denne porten deaktiverer funksjonen for konfliktregistrering av PDM IP, slik at den ikke kan identifisere IP-adresser som er i bruk.
Som en alternativ løsning kan du legge til en egendefinert intern programvareregel i Avamar-konfigurasjonen for å håndtere dette scenariet. Hvis du vil ha detaljerte instruksjoner, kan du se følgende kunnskapsbaseartikkel: 000019911