NetWorker: Oracle backup fail with lockbox error during any failover of NetWorker server

Resumo: When NetWorker cluster service failover from one node to another, the Oracle backup failed with lockbox error

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Sintomas

No Changes but *@* was presented in the Remote Access field of the NetWorker Server client resource

No Oracle backup. Need to delete or modify the client wizard for the RMAN option to get the backup working on the failed over node

During the failover of NetWorker cluster service, the Oracle backup failed with the following error:

Oracle_Client:     Unable to obtain the user credentials from the lockbox due to the following error: 'Failed to open lockbox D:\nsr\lockbox\Oracle_Client\clb.lb'.Confirm that the user 'xyz' on the host 'Oracle_Client' is in the Users attribute of the lockbox resource.

Causa

The Remote Access Field of the NetWorker Server resource (the NetWorker Cluster name) have *@*.
If *@* presented in the Remote access list, then there is no information in RAP DB that would tell NetWorker what the other node is, and NetWorker don t have an ability to authorize all hosts (even if did, NetWorker wouldn t do that, as that would be a huge security hole).  The lockbox on the active node was likely created on the active and the passive node was not added to the allowed list (this is what the error  The system hostname key is missing  means.  This lockbox is likely going to open fine on the other node and will only have active node in the list.

Resolução

Applied the following to the "Remote Access" Field of the NetWorker Server Resource (NetWorker cluster name):

*@Physical_Node1
*@Physical_Node2

Run the backup and all OK. The lockbox information updated correctly with both physical node information.
No need to delete the Oracle client or modify

Produtos afetados

NetWorker

Produtos

NetWorker
Propriedades do artigo
Número do artigo: 000067776
Tipo de artigo: Solution
Último modificado: 03 mai. 2024
Versão:  4
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