NetWorker: Oracle-varmuuskopiointi epäonnistuu ja näyttää Lockbox-virheen kaikissa NetWorker-palvelimen vikatilanteissa

Resumo: Kun NetWorker-klusterin palvelu siirtyy vikatilanteessa solmusta toiseen, Oracle-varmuuskopiointi epäonnistui ja näytti Lockbox-virheen

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Ei muutoksia, mutta *@* näkyi NetWorker Server -asiakasresurssin Remote Access -kentässä

Ei Oracle-varmuuskopiointia. Ohjattu asiakastoiminto on poistettava tai sitä on muutettava, jotta RMAN-asetus saa varmuuskopioinnin toimimaan vikasietoisessa solmussa

NetWorker-klusteripalvelun vikatilanteessa Oracle-varmuuskopiointi epäonnistui ja näytti seuraavan virheen:

Oracle_Client:     Unable to obtain the user credentials from the lockbox due to the following error: 'Failed to open lockbox D:\nsr\lockbox\Oracle_Client\clb.lb'.Confirm that the user 'xyz' on the host 'Oracle_Client' is in the Users attribute of the lockbox resource.

Causa

NetWorker Server -resurssin Remote Access Field -kentässä (NetWorker Cluster -nimi) on *@*.
Jos Remote access -luettelossa on *@*, RAP DB:ssa ei ole tietoa, joka ilmoittaisi NetWorkerille, mikä toinen solmu on, ja NetWorker ei pysty valtuuttamaan kaikkia isäntiä (ja vaikka pystyisikin, NetWorker ei tekisi sitä, koska se olisi valtava tietoturva-aukko).  Aktiivisen solmun Lockbox on todennäköisesti luotu aktiivisessa solmussa ja passiivista solmua ei ole lisätty sallittujen luetteloon (sitä tarkoittaa virhe The system hostname key is missing).  Tämä Lockbox avautuu todennäköisesti normaalisti toisessa solmussa, ja sen luettelossa näkyy vain aktiivinen solmu.

Resolução

Lisätty seuraava NetWorker Server Resourcen (NetWorker-klusterin nimi) "Remote Access" -kenttään:

*@Physical_Node1
*@Physical_Node2

Tehtiin varmuuskopiointi, kaikki kunnossa. Molempien fyysisten solmujen tiedot päivittyivät oikein Lockbox-tietoihin.
Oracle-asiakasta ei tarvitse poistaa tai muuttaa

Produtos afetados

NetWorker

Produtos

NetWorker
Propriedades do artigo
Número do artigo: 000067776
Tipo de artigo: Solution
Último modificado: 03 mai. 2024
Versão:  4
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.