PowerProtect Data Manager: Search engine failed with Cluster is not operational

摘要: PowerProtect Data Manager Search engine failed after deployment with "Cluster is not operational. API Service is not running on node:" Search engine status is ready.

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症状

The PowerProtect Data Manager (PPDM) Search engine fails after it is deployed with the following message.
"Cluster is not operational. API Service is not running on node:" Search engine status is ready.

The following key error is displayed in the VMDM log:

2023-03-13T06:48:55.138Z ERROR [Timer-1] [][][][][] [c.e.b.v.v.s.h.SearchUpdateHelper.getSearchTelemetry(352)] -  Failed to get telemetry data 
com.emc.brs.vmdm.error.ComponentException: org.springframework.web.client.HttpClientErrorException$Unauthorized: 401 Unauthorized: "The user does not have authorization to access this API<EOL>The user does not have authorization to access this API<EOL>"

 

原因

"The user does not have authorization to access this API"
This message indicates that the Search Node is not able to resolve the PPDM fully qualified domain name. It is unable to talk with the PPDM instance.

解决方案

Check for DNS issues:

  1. Log in to the Search Node
  2. Perform a lookup of the PPDM instance's fully qualified domain name. nslookup <PPDM FQDN
  3. The lookup should successfully resolve. If the resolution fails, there is an issue with the DNS provided when Search Node is configured. Alternatively, there may have been a change in DNS configuration. If this is the initial configuration of the Search Node, correct the DNS value and reconfigure it.


Otherwise, add the PPDM server to the DNS entry of the DNS server, once the search node is configured.

Steps to retrieve Search Node credential:

  1. On the PPDM appliance, switch to the root user.
  2. Run the following commands.
source /opt/emc/vmdirect/unit/vmdirect.env
/opt/emc/vmdirect/bin/infranodemgmt get --secret

 

受影响的产品

PowerProtect Software
文章属性
文章编号: 000211378
文章类型: Solution
上次修改时间: 18 9月 2025
版本:  3
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