Dell VxRail: Internet Updates Showing: "No Available System Updates."
Summary: Internet updates are returned with a message showing: "No Available System Updates."
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Symptoms
Internet Updates appear with "No Available System Updates."

Figure 1: Updates appear with "No Available System Updates."
Message seen in short.term.log:
"2023-07-05 19:31:44,299" microservice.do-ecosystem "2023-07-05T19:31:43.496634511Z stderr F raise MaxRetryError(_pool, url, error or ResponseError(cause))"
"2023-07-05 19:31:44,299" microservice.do-ecosystem "2023-07-05T19:31:43.496637421Z stderr F urllib3.exceptions.MaxRetryError: HTTPSConnectionPool(host='colu.dell.com', port=443): Max retries exceeded with url: /soap/rpc (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed: 407 Proxy Authentication Required',)))"
"2023-07-05 19:31:44,299" microservice.do-ecosystem "2023-07-05T19:31:43.496701844Z stderr F 2023-07-05 19:31:43,496 [INFO] <Dummy-63:140238496454728> acgcataservice.py get_catalogs() (80): Close client object instance"
Cause
If a Proxy is used that requires authentication but credentials are not provided, Internet updates may show no available updates.
Resolution
To resolve this issue, update the VxRail manager proxy configuration to use credentials to authenticate with the server.
Cluster > Configure > VxRail > Networking > Edit Proxy Settings:

Figure 2: Enter Proxy Server Credentials username and password.
Affected Products
VxRailArticle Properties
Article Number: 000215570
Article Type: Solution
Last Modified: 09 Aug 2023
Version: 2
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