Data Domain Management Center genstarter hver time efter opgradering
Oversigt: Systemet genstarter spontant ca. hver time efter opgradering af PowerProtect DD Management Center (DDMC). Dette sker på grund af et problem med filen til kørsel af Docker Process Identifier (PID). ...
Denne artikel gælder for
Denne artikel gælder ikke for
Denne artikel er ikke knyttet til et bestemt produkt.
Det er ikke alle produktversioner, der er identificeret i denne artikel.
Symptomer
- Efter opgraderingen genstarter DDMC næsten hver time.
- Der er ingen indlysende meddelelser i kern.info eller messages.engineering, der angiver, hvorfor systemet blev genstartet
- Logmeddelelser, der ligner nedenstående, findes i /ddr/var/log/debug/docker/psm.log:
01/31 10:16:27.951 ERROR: run_cmd: stderr: None 01/31 10:16:27.951 ERROR: run_cmd: stdout: b'Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?\n'
Årsag
Dette er en sjælden situation, hvor docker blev lukket uværdigt ned, og PID-filen (var/run/docker.pid) ikke ryddes korrekt. Docker kan ikke starte, når der er en eksisterende PID-fil. Dette er forventeligt.
Løsning
På grund af at systemet genstarter ugraciøst, kører mekanismen, der fjerner den forældede PID-fil, aldrig. Hvis du efter DDMC genstarter en manuel genstart af DDMC, bør dette stoppe genstartsløjfen.
Hvis ikke, skal du kontakte Dell Support, hvorefter en tekniker manuelt kan fjerne docker PID-filen fra DDMC i bash:
Hvis ikke, skal du kontakte Dell Support, hvorefter en tekniker manuelt kan fjerne docker PID-filen fra DDMC i bash:
# rm /var/run/docker.pid
Artikelegenskaber
Artikelnummer: 000221727
Artikeltype: Solution
Senest ændret: 13 feb. 2024
Version: 1
Find svar på dine spørgsmål fra andre Dell-brugere
Supportservices
Kontrollér, om din enhed er dækket af supportservices.