Data Domain Management Center Reboots Hourly After Upgrade

Oversigt: The system reboots spontaneously approximately every hour after upgrading PowerProtect DD Management Center (DDMC). This happens due to an issue with the docker process identifier (PID) run file. ...

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Symptomer

  • After the upgrade, the DDMC reboots on an almost hourly cadence.
  • There are no obvious messages in kern.info or messages.engineering to indicate why the system was rebooted
  • Log messages similar to the below are present in /ddr/var/log/debug/docker/psm.log:
01/31 10:16:27.951 ERROR: run_cmd: stderr: None
01/31 10:16:27.951 ERROR: run_cmd: stdout: b'Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?\n'

Årsag

This is a rare situation where docker was ungracefully shut down and the PID file (var/run/docker.pid) is not correctly cleared. Docker cannot start when there is an existing PID file. This is expected behavior.

Løsning

Due to the system rebooting ungracefully, the mechanism that removes the stale PID file never runs. After the DDMC reboots, if you initiate a manual reboot of the DDMC, this should stop the reboot loop.

If not, contact Dell Support and an engineer can manually remove the docker PID file from the DDMC in bash:
# rm /var/run/docker.pid
Artikelegenskaber
Artikelnummer: 000221727
Artikeltype: Solution
Senest ændret: 13 feb. 2024
Version:  1
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