Data Protection Advisor (DPA): PPDM data collection request fails with function caught InvalidStatusException

Summary: PPDM data collection request fails with message function caught InvalidStatusException

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The History section of the PPDM Job Monitor data collection request has the following status message:
Function jobmonitor caught ProcessingException

The same message occurs in the dpaagent.log after requesting an API response from the PPDM server:
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute(): Function jobmonitor caught InvalidStatusException

Cause

The API request before the ERR did not respond with an expected status.
The debug low dpaagent.log shows the API request which generated the exception:

DBG1 12669.12677 20210211:071704 com.emc.dpa.agent.co - get(): GET [/api/v2/assets?pageSize=5000&page=1]
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute(): Function jobmonitor caught InvalidStatusException


Using a rest client, the request /api/v2/assets?pageSize=5000 was generating the following message from the PPDM server after 60sec:

{ "reason" : "Gateway Timeout Error.", "remediation" : "Try the operation again later.", "code" : 504, "path" : "/api/v2/assets", "timestamp" : 1613473517745 }

The Gateway Timeout Error comes from PPDM after 60sec regardless of the timeouts we set on the DPA request.
The API request /api/v2/assets?pageSize=100 returns information successfully from the same PPDM server.

Resolution

DPA is working as designed.
The PPDM server is returning an unexpected status for the API request due to a performance issue.
This issue needs to be investigated from the PPDM side.

Please contact Dell Technical Support for further information.

Products

Data Protection Advisor
Article Properties
Article Number: 000184325
Article Type: Solution
Last Modified: 12 Nov 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.