Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Using Windows logs to troubleshoot wireless issues only seen at customer locations

Summary: This article provides the information about capturing an Event Trace Log (ETL). It includes the ETL and other files that can assist Dell in troubleshooting wireless issues only seen at customer sites. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

The Windows operating system has numerous logs that can be beneficial when analyzing wireless issue at the customer location. Especially when those issues cannot be replicated in other network environments.

Cause

Locating, creating, and exporting the logs

Logs that already exist from prior testing:

  1. Before you encountered the computer, there may have been logs created that can be valuable. The WLANAutoconfig.log file in Event Viewer (If not already compiled into to a CAB file) can be found and saved manually in the Windows Event Viewer:
    1. In Event Viewer, go to Applications and Service Logs.
    2. Go to Microsoft.
    3. Go to Windows.
    4. Then open the Wlan-autoconfig folder.
  2. The NETSH script below outputs to the C:\wlogs folder:

WLAN-autoconfig Diagnostic Logging

You can enable the WLAN-autoconfig Diagnostic log on the System Under test (SUT) prior to future testing. This might help with some more verbose log messages. Use the following instructions.

To enable the diagnostic log:

  1. Open Event Viewer, and navigate to:
    1. The Applications and Service Logs
    2. Then Microsoft
    3. Then Windows
    4. Then Wlan-Autoconfig
  2. Right-click the Wlan-Autoconfig folder.
  3. Then select View.
  4. Show the Analytic and Debug logs.
  5. The diagnostic log appears under the Autoconfig folder.
  6. Right-click the diagnostic log and choose: Enable the log

Resolution

NOTE: There is one caveat. This log must be manually saved from the event viewer in order to share it with Dell after testing. It may not automatically be in the NETSH output cab folder.

Netsh script text for reference: (Copy the text below and paste into a notepad and save the file as ETL.BAT)

@echo off

rem PASTE THIS SCRIPT INTO NOTEPAD AND SAVE AS A .BAT FILE. RT CLICK THE FILE AND RUN AS ADMINISTRATOR.

rem DO NOT CREATE DIRECTORY IF IT ALREADY EXISTS
if exist c:\wlogs goto SKIPMKDIR
mkdir c:\wlogs
:SKIPMKDIR

rem BEGIN TRACE
netsh ras set tracing * enable

rem BUNDY, I WOULD LIKE TO DYNAMICALLY GENERATE THE FILENAME wlan001.etl TO AVOID WRITING OVER PREVIOUS LOGS
SET file1=1
IF EXIST c:\wlogs\wlan%file1%.etl GOTO nextlog
netsh trace start scenario=wlan tracefile=c:\wlogs\wlan1.etl capture=yes persistent=yes maxsize=250 report=yes
filemode=append
GOTO filedone
:nextlog
SET /A "file1+=1" IF EXIST c:\wlogs\wlan%file1%.etl GOTO nextlog
netsh trace start scenario=wlan tracefile=c:\wlogs\wlan%file1%.etl capture=yes persistent=yes maxsize=250 report=yes
filemode=append

:filedone
rem DISPLAY PROMPT TO PRESS ANY KEY TO STOP THE CAPTURE
set /p =Press any key to stop the capture. < nul
pause > nul

rem STOP TRACE
netsh trace stop

rem DISPLAY RESULTS AND PROMPT TO HIT ANY KEY BEFORE ENDING
pause

Article Properties


Affected Product

Desktops & All-in-Ones, Laptops

Last Published Date

10 Oct 2023

Version

5

Article Type

Solution