Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Brug af Windows-logfiler til fejlfinding af trådløse problemer, som kun opleves på kundens lokationer

Summary: Denne artikel indeholder oplysninger om optagelse af en hændelsessporingslog (ETL). Det omfatter ETL og andre filer, der kan hjælpe Dell med fejlfinding af trådløse problemer, som kun opleves på kundens lokationer. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Windows-operativsystemet har adskillige logfiler, der kan være fordelagtige, når der analyseres problemer med trådløs forbindelse på kundens adresse. Især når disse problemer ikke kan replikeres i andre netværksmiljøer.

Cause

Find, opret og eksporter logfilerne

Logfiler, der allerede eksisterer fra tidligere test:

  1. Inden du fandt computeren, kan der være oprettet logfiler, der kan være værdifulde. Filen WLANAutoconfig.log i Logbog (hvis den ikke allerede er kompileret til en CAB-fil) kan findes og gemmes manuelt i Windows Logbog:
    1. I Logbog skal du gå til Programmer og servicelogfiler.
    2. Gå til Microsoft.
    3. Gå til Windows.
    4. Åbn Wlan-autoconfig derefter mappen.
  2. Scriptet NETSH nedenfor udskrives til mappen C:\wlogs :

WLAN-autoconfig Logføring af diagnosticering

Du kan aktivere diagnosticeringslogfilen WLAN-autoconfig på systemet under test (SUT) før fremtidig testning. Dette kan hjælpe med nogle flere detaljerede logmeddelelser. Brug følgende vejledning.

Sådan aktiveres diagnosticeringsloggen:

  1. Åbn Logbog, og naviger til:
    1. Programmer og servicelogfiler
    2. og derefter Microsoft
    3. Og derefter Windows
    4. Derefter Wlan-Autoconfig
  2. Højreklik på Wlan-Autoconfig mappen.
  3. Vælg derefter Vis.
  4. Vis logfiler for analyse og fejlfinding .
  5. Diagnosticeringsloggen vises under mappen Autoconfig.
  6. Højreklik på diagnosticeringsloggen , og vælg: Aktiver loggen

Resolution

BEMÆRK: Der er én advarsel. Denne log skal gemmes manuelt fra logbogen for at kunne dele den med Dell efter testning. Den findes muligvis ikke automatisk i NETSH output-CAB-mappen.

Netsh scripttekst til reference: (Kopier teksten nedenfor, indsæt den i en Notesblok, og gem filen som ETL.BAT)

@echo off

rem PASTE THIS SCRIPT INTO NOTEPAD AND SAVE AS A .BAT FILE. RT CLICK THE FILE AND RUN AS ADMINISTRATOR.

rem DO NOT CREATE DIRECTORY IF IT ALREADY EXISTS
if exist c:\wlogs goto SKIPMKDIR
mkdir c:\wlogs
:SKIPMKDIR

rem BEGIN TRACE
netsh ras set tracing * enable

rem BUNDY, I WOULD LIKE TO DYNAMICALLY GENERATE THE FILENAME wlan001.etl TO AVOID WRITING OVER PREVIOUS LOGS
SET file1=1
IF EXIST c:\wlogs\wlan%file1%.etl GOTO nextlog
netsh trace start scenario=wlan tracefile=c:\wlogs\wlan1.etl capture=yes persistent=yes maxsize=250 report=yes
filemode=append
GOTO filedone
:nextlog
SET /A "file1+=1" IF EXIST c:\wlogs\wlan%file1%.etl GOTO nextlog
netsh trace start scenario=wlan tracefile=c:\wlogs\wlan%file1%.etl capture=yes persistent=yes maxsize=250 report=yes
filemode=append

:filedone
rem DISPLAY PROMPT TO PRESS ANY KEY TO STOP THE CAPTURE
set /p =Press any key to stop the capture. < nul
pause > nul

rem STOP TRACE
netsh trace stop

rem DISPLAY RESULTS AND PROMPT TO HIT ANY KEY BEFORE ENDING
pause

Article Properties


Affected Product

Desktops & All-in-Ones, Laptops

Last Published Date

10 Oct 2023

Version

5

Article Type

Solution