SRM 3.7: New installation gets error message "Database connection failed Please Contact your Frontend administrator"
Summary: New installation of SRM 3.7 fails with error message "Database connection failed! Please Contact your Frontend administrator"
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Symptoms
This was a new SRM 3.7 vApp (4VM) installation. After the initial startup and module are complete, the login prompt displays this message:
Cause
Front-End Appliance DNS servers' IP addresses are wrong.
Resolution
To address the issue:
Use the vSphere client to stop the vApp.
Procedure:
Use the vSphere client to stop the vApp.
Procedure:
- In the vSphere client, go to the Host >Cluster View.
- From the Configured Resource Pool, find the resource pool that you selected for the appliance. The new appliance is listed under the resource pool.
- Right-click the vApp, and select Power Off
- Right-click the vApp, scroll down, and select Edit Settings, to bring up Edit vApp Settings dialog.
- Click Options > Properties
- Under vApp Property Configuration, for each SRM appliance, scroll down to Front-End Appliance DNS servers

- Correct the IP addresses of the DNS servers and click Ok
- Right-click the vApp, and select Power On
- Test that the login prompt display successfully.
Article Properties
Article Number: 000059222
Article Type: Solution
Last Modified: 11 Nov 2025
Version: 4
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