PowerStore: Health check for a component firmware check may fail if power supply has been replaced in the past
Summary: Health check for a component firmware check may fail if a power supply has been replaced in the past.
Symptoms
The health check for a "Component Firmware Check" may fail, and the firmware for the power supply in the appliance is marked as "Upgrade needed".
| $ svc_health_check run : Component Firmware Check node_a Failed Components Firmware needs to be upgraded (KB#000201500) Component Firmware Check node_b Failed Components Firmware needs to be upgraded (KB#000201500) |
Cause
If there is a history that a Power Supply (PS) in an appliance has been replaced in the past, and Node A has not been rebooted since then, the PS firmware was not upgraded and may remain as old as it was when the replacement parts had an older firmware version than the firmware package in the repository with a currently running PowerStoreOS. This is a design specification (FAD). Firmware updates for power supplies (PSUs) will only be initiated if the BMC detects older firmware during the POST phase. Please note that Node A is responsible for triggering updates for both PSUs, by design.
Resolution
This does not affect normal operation immediately under these conditions, but it is suggested that it be resolved prior to NDU operation, by following the steps below.
To recover the condition once, it has occurred
- Check if there is a history that the Power Supply(s) of the appliance have been replaced in the past.
- Check that Node A has not been rebooted since then.
- If the above condition is met, verify that both PSUs are healthy and supplying input power. Then perform a manual Node A reboot that initiates the PS0 and/or PS1 firmware upgrade.
NOTE:
- Make sure to verify Node B is up and healthy status before proceeding with Node A reboot.
- Ensure all host initiators re properly connected to both nodes.
4. Re-Run the Health Check again to see if the Component Firmware Check will pass.
If after following instructions in this article, the issue persists, contact Dell Technical Support for assistance.
Reference this KB# 000218742 in the Service Request for expedited handling.