DD is Refusing the Single Sign-On Connection to DPC, Issue Must be Checked from DD

Summary: Unable to register a Data Domain at the Data Protection Central (DPC) console.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

From DDOS 6.2.0.20 and later, DDOS added Single Sign-On (SSO) authentication for Data Protection Central (DPC). This SSO allows access to the PowerProtect DD System Manager UI from DPC without using DD credentials.

The DPC Data Domain integration requires registration of the Data Domain at the DPC console. This may fail with the error "Failed to get SSO auth endpoints" reported at Data Domain sms.info debug logs under /ddr/var/log/debug/sm directory.

Cause

The registration process requires the Data Domain to resolve the DPC FQDN and DPC hostname IP address. If the Data Domain is unable to resolve them, the error is reported at Data Doman sms.info debug logs as "Failed to get SSO auth endpoints."

Resolution

Ensure that the DPC FQDN and DPC hostname are properly resolved by the Data Domain either by DNS or local host resolution. These can be added to the list of known Data Domain hosts.

  • At DD CLI, add the DPC FQDN IP address, DPC Hostname, and DPC FQDN to the list of known Data Domain hosts using the following command:
# net hosts add {<ipaddr> | <ipv6addr>} <host-list>
                                       Add a host list entry
Caution: If you are unsure about any of the steps or have concerns, contact Dell Support for assistance.
Note: Ensure that you have the necessary permissions and access rights to perform the required actions.

 

Affected Products

Data Protection Central, Data Domain, DD OS
Article Properties
Article Number: 000054109
Article Type: Solution
Last Modified: 25 Mar 2025
Version:  5
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