Connectrix: Pmon Service Results in Disruptive Reload When Running `show tech` Commands
Summary: Pmon service results in disruptive reload while running `show tech` commands.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The pmon service crashes and restarts while running the show port-monitor internal event-history debug command.
This has been seen on the NX-OS 9.4.1 code family.
This command is part of the following commands, and so they can trigger this issue:
show tech-support show tech-support details show tech-support fpm
The following syslog is logged to show the logging logfile:
%SYSMGR-3-HEARTBEAT_FAILURE: Service "PMon" sent SIGABRT for not setting heartbeat for last 4 period s. Last heartbeat 46.91 secs ago. %SYSMGR-2-SERVICE_CRASHED: Service "PMon" (PID ...) hasn't caught signal 6 (core will be saved). This issue applies to all MDS platforms. At least one Port Monitor policy must be active and applied to at least one interface.
Cause
Cisco issue CSCwh76823
This issue applies to all MDS platforms.
At least one Port Monitor policy must be active and applied to at least one interface. This issue occurs if there are excessive delays in collecting the internal Port Monitor debug log from a module.
Resolution
Fix:
Upgrade to a version later than 9.4.1a
Workaround:
Do not run the following commands:
show tech-support show tech-support details show tech-support fpm show port-monitor internal event-history debug
Affected Products
Connectrix MDS-Series HardwareArticle Properties
Article Number: 000328074
Article Type: Solution
Last Modified: 04 Jun 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.