PowerEdge: Windows Server 22 Patch KB5022291 update Causes Blue Screen Error

Summary: Installation of January 10, 2023 patch KB5022291 on Windows Server 2022 may result in Blue Screen error on the following systems and configurations. Dell 14G PowerEdge Server with Intel Optane persistent memory Series 100 configured in App Direct mode is affected. Dell 15G PowerEdge Server with Intel Optane persistent memory Series 200 configured in App Direct mode is affected. Note: Memory Settings configured in Memory Mode in the BIOS function correctly with KB5022291 or higher version of Windows Server 2022 updates. Optane Series 100 Memory Mode is Persistent Memory set to Off. Optane Series 200 Memory Mode has Optane DIMMs disabled under Memory Mapout. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

User may see a Blue Screen Error with stop code SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e) after installing January 10, 2023 Cumulative Update KB5022291, if using Intel Optane Series 100 or Series 200 with App Direct Mode.

The operating system will not complete the boot process.
 
Optane BlueScreen Error
 

Cause

The root cause is understood to be the change in pci.sys code released in January 10, 2023—KB5022291 that causes a divide by zero crash when a NUMA node does not have any processor cores assigned.

Resolution

Do not replace hardware.

The resolution involves disabling persistent memory in the BIOS, updating Windows Server 2022 with August 8, 2023 KB5029250, and then re-enabling persistent memory in the BIOS.


Disable persistent memory in the BIOS settings.
Optane Series 200: BIOS Setup Menu (F2) -> System BIOS -> Memory settings > Memory Mapout > disable the slots in which PMEM is installed.

Memory Mapout Disabled

Optane Series 100: BIOS Setup Menu (F2) -> Persistent Memory -> Persistent Memory > Turn it OFF.

Persistent Memory Off

Save and exit BIOS.
Boot to the OS.

Update the Windows OS to August 8,2023 KB5029250 Cumulative Update, or later. Reboot the system for the changes to be complete.
Boot back into the OS, go to Settings, System, About and verify that the OS Build is 20348.1906 or greater.


OS Build version

Reboot the server back to the OS.
Trigger another Reboot and go to the BIOS Setup Menu (F2).
Re-Enable the App Direct Mode in the BIOS settings.
Optane Series 200: BIOS Setup Menu(F2) -> System BIOS -> Memory settings > Memory Mapout > enable the slots in which PMEM is installed.
Optane Series 100: BIOS Setup Menu(F2) -> Persistent Memory -> Persistent Memory> Select Non-Volatile DIMM
Save and exit BIOS.
Boot back to the OS.
 

 

Affected Products

Microsoft Windows Server 2022, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650 , PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760xd2, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000212707
Article Type: Solution
Last Modified: 09 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.