TLS-Kommunikationsproblem in Dell Data Protection Virtual Edition
Summary: Dell Data Protection Virtual Edition v9.2 und früher kann Probleme mit der TLS-Kommunikation haben.
Symptoms
Betroffene Produkte:
- Dell Data Protection | Virtual Edition
Betroffene Versionen:
- v9.2 und früher
Client Security Framework (Agent)-Richtlinien werden nicht ordnungsgemäß abgerufen. Dies ist auf die TLS-Kommunikation mit dem Back-end-Server zurückzuführen.
Cause
Dieser Fehler ist in der Regel mit Dell Data Protection verbunden | Virtual Edition v9.2 und früher, bei der der Core-Server nur auf TLS 1.0 kommunizieren konnte. Neuere Versionen (9.3 und höher) verfügen über einen neuen Service mit dem Namen Core HA Proxy und können bis zu TLS 1.2 kommunizieren.
Wenn die folgenden Fehler angezeigt werden, ist ein Upgrade erforderlich, um das Problem zu beheben:
2016.04.05 16:09:09 I Comm : opening connection to "https://:8888/agent" 2016.04.05 16:09:11 E Comm : communication exception - An error occurred while making the HTTP request to https://.com:8888/agent. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server.: The underlying connection was closed: An unexpected error occurred on a send. 2016.04.05 16:09:11 I Comm : next contact with server scheduled for 4/5/2016 4:10:11 PM 2016.04.05 16:10:11 I Comm : opening connection to "https://:8888/agentv2" 2016.04.05 16:10:12 E Comm : communication exception - An error occurred while making the HTTP request to https://:8888/agentv2. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server.: The underlying connection was closed: An unexpected error occurred on a send.
Resolution
Das Problem wurde in Version 9.3 und höher behoben.
Um das Problem zu beheben, aktualisieren Sie den Server auf die aktuelle Version.
Nutzen Sie zur Kontaktaufnahme mit dem Support die internationalen Support-Telefonnummern von Dell Data Security.
Gehen Sie zu TechDirect, um online eine Anfrage an den technischen Support zu erstellen.
Zusätzliche Einblicke und Ressourcen erhalten Sie im Dell Security Community Forum.