TLS Communication Issue in Dell Data Protection Virtual Edition

Summary: Dell Data Protection Virtual Edition v9.2 and earlier may have issues with TLS Communication.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Data Protection | Virtual Edition

Affected Versions:

  • v9.2 and Earlier

Client Security Framework (agent) policies do not pull properly. This is due to TLS communication to the backend server.

Cause

This error is typically linked to Dell Data Protection | Virtual Edition v9.2 and earlier, where the core server could only talk on TLS 1.0. Newer versions (9.3 and later) have a new service that is named Core HA Proxy and it can communicate up to TLS 1.2.

When the below errors are seen, an upgrade is necessary to resolve the issue:

2016.04.05 16:09:09 I Comm : opening connection to "https://<server.domain.com>:8888/agent"
2016.04.05 16:09:11 E Comm : communication exception - An error occurred while making the HTTP request to https://<server.domain>.com:8888/agent. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server.: The underlying connection was closed: An unexpected error occurred on a send.
2016.04.05 16:09:11 I Comm : next contact with server scheduled for 4/5/2016 4:10:11 PM
2016.04.05 16:10:11 I Comm : opening connection to "https://<server.domain.com>:8888/agentv2"
2016.04.05 16:10:12 E Comm : communication exception - An error occurred while making the HTTP request to https://<server.domain.com>:8888/agentv2. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server.: The underlying connection was closed: An unexpected error occurred on a send.
Note: <server.domain.com> is replaced with your configured server FQDN, Hostname, or IP Address.

Resolution

Issue was resolved in v9.3 and later.

To resolve issue, upgrade server to current version.


To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

Affected Products

Dell Encryption
Article Properties
Article Number: 000126131
Article Type: Solution
Last Modified: 03 Aug 2023
Version:  10
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