PowerProtect Data Manager: Agent Plugin Registration Fails with "Cannot Connect to Proxy"

Summary: PowerProtect Data Manager Agent plugin fails registration with "cannot connect to proxy" error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

If there are any details of the Symptoms these show here, and if there are any items to follow it shows in the below log.


The following error message is found in the OpAgentSvc.log:

Traceback (most recent call last):
File "Http\HTTPServer.py", line 5524, in sendCSR
File "requests\api.py", line 115, in post
File "requests\api.py", line 59, in request
File "requests\sessions.py", line 587, in request
File "requests\sessions.py", line 701, in send
File "requests\adapters.py", line 559, in send
requests.exceptions.ProxyError: HTTPSConnectionPool(host='gcpppdmdb01.hhcsystem.org', port=8443): Max retries exceeded with url: /api/v2/adm/agentRegistration (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed: 403 Forbidden')))
[2025-01-08 19:00:39,777 GMT| 2025-01-08 14:00:39,777047 Eastern Standard Time| DBGHTTPSERVER| PID-21584| TID-6244| INFO] C:\Program Files\DPSAPPS\AgentService\tmp\_MEI138882\Http\HTTPServer.pyc-sendCSR()-Line 5534- Remediation : Send CSR request failed. The PowerProtect Data Manager server is not accessible.

Cause

Check the system and confirm that system variables have been defined for proxy use:

set | findstr /I proxy

If HTTPS_PROXY and HTTP_PROXY are defined, You must define a NO_PROXY environment variable to bypass the proxy.

If HTTPS_PROXY and HTTP_PROXY are defined, but NO_PROXY is not, it may cause the PPDM Agent plugin registration to fail with a cannot connect to proxy; error.

Resolution

The NO_PROXY environment variable must be defined with the addresses or fully qualified domain names that must bypass the proxy servers.

To setup windows environment variable NO_PROXY permanently: 

  • Open the Start menu and search for Environment Variables.   
  • Select Edit the system environment variables.   
  • In the System Properties window, click Environment Variables.   
  • Under User variables or System variables, click New.   
  • Add NO_PROXY as the Variable name and a comma-separated list of domains or addresses as the Variable value (for example, PPDM_FDQN,DD_FQDN,IP_of_PPDM,IP_of_DD).   
  • Click OK to save.

Restart the PPDM agent service and retry the registration.

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000276524
Article Type: Solution
Last Modified: 28 Jan 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.