PowerStore: Intermittent Data Collection Failures, Service Container OOM caused by Python 2 Limitations
Summary: Intermittent Data Collection failures due to service container out-of-memory (OOM) caused by Python 2 limitation
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Intermittent data collection job failures may occur, with one of the status messages reporting:
FAILURE, Running too long.
Cause
- Intermittent data collection job failures may occur due to an OOM condition in the service container on a primary node.
- This memory optimization and garbage collection limitations in Python 2 may cause the issue, leading to increased memory usage by the
service_serviceabilityandfiremanprocesses in each data collection job and eventually experiencing the OOM condition. - The issue is more likely to occur if a remote syslog server is configured, but can also happen depending on the environment or configuration.
Resolution
The issue is addressed in PowerStoreOS 4.1 and later.
Affected Products
PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore Expansion Enclosure, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore Rack, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 5200T
, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T
...
Article Properties
Article Number: 000318294
Article Type: Solution
Last Modified: 11 Jul 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.